Wordpress issue - help please Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
albeck
Posts: 15
Joined: Sun Dec 06, 2020 1:09 am

Wordpress issue - help please

Post by albeck »

placeholder.jpg
This is the page that I get instead of my Wordpress site when I type my domain as "<www.mysite. <com>". If I type "<www.mysite.<com>/wordpress>" this works on my LAN but not outside of my network on the Internet (I have a static ip and DNS forwarded to port 80 via NameCheap).

I installed Wordpress via "dietpi-software" script, which works very well and uses lighttpd.

I'm really stuck with this install and after 3 days trying.

Any help very much appreciated. Thank you.
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Wordpress issue - help please

Post by Joulinar »

Hi,

pls can you stop recreating the topic again and again and again. This is now the 3rd or 4th time your have open the same while deleting the old one. thx
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
albeck
Posts: 15
Joined: Sun Dec 06, 2020 1:09 am

Re: Wordpress issue - help please

Post by albeck »

Apologies - I'm new to this and struggling. I was trying to put examples of www of my site without actually linking to the web but didn't get it right, so tried to delete and rewrite more than once - sorry.
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Wordpress issue - help please

Post by Joulinar »

Hi,

basically you can adjust your post. No need to delete and recreate. Back to your topic. Did you adjusted WP settings WordPress Address (URL) as well as Site Address (URL) pointing to our DDNS?

On my test this was needed to get WP reachable from internet.

picture.PNG
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
albeck
Posts: 15
Joined: Sun Dec 06, 2020 1:09 am

Re: Wordpress issue - help please

Post by albeck »

Many thanks. This worked and to add you need to copy index.php to www (root).
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Wordpress issue - help please

Post by Joulinar »

usually moving index.php should not be needed
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
albeck
Posts: 15
Joined: Sun Dec 06, 2020 1:09 am

Re: Wordpress issue - help please

Post by albeck »

No, don't move index.php please copy to root (www) and leave copy of index.php in subdomain (wordpress). Change the following and save the index.php file in root. Change the line that says:require( dirname( __FILE__ ) . '/wp-blog-header.php' );to the following, using your directory name for the WordPress core files:require( dirname( __FILE__ ) . '/wordpress/wp-blog-header.php' );
Don't edit the copy of index.php in wordpress subdomain.
Delete index.lighttpd.html from root to remove landing page.
Wordpress settings: change site url to yourwebite(.com)

For full instructions: https://wordpress.org/support/article/g ... directory/
Post Reply