Certbot failed with error code (1) Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
nanooker
Posts: 17
Joined: Sun Dec 06, 2020 7:41 pm

Re: Certbot failed with error code (1)

Post by nanooker »

I hope I may join you here

I have the same problem. I do not have a no-ip account but "dyn6.com". With my registered ip at dyn6.com i can't reach my system. In my router is another ip. it is a PPPoE account. With this IP I can reach my router.
I can not replace this IP in the account of dyn6.com. No idea why not?
The error message for letsencrypt is
[FAILURE] Certbot failed with error code (1), please check its terminal output. Aborting...
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Certbot failed with error code (1)

Post by Joulinar »

Hi,

you need to ensure the IP resisted at dyn6.com is the same as the WAN IP on your router.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
nanooker
Posts: 17
Joined: Sun Dec 06, 2020 7:41 pm

Re: Certbot failed with error code (1)

Post by nanooker »

I have changed the Wan IP under dyn6
With this ip i can access my security gateway/router.
The port release refers to the Wan ip with 80 and 443 TCP.
The dyndns is set up on the router with the access data from dynv6.com.
But i still get the same error message when setting up letsencrypt.
I have installed the Baikal Webdav. It runs and synchronizes perfectly. But without tls encryption it makes no sense.
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Certbot failed with error code (1)

Post by Joulinar »

you need to ensure you are able to reach your system on http://<your_domain.dynv6.com>
That's key. As soon as this is working you could try to configure HTTPS/SSL
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
nanooker
Posts: 17
Joined: Sun Dec 06, 2020 7:41 pm

Re: Certbot failed with error code (1)

Post by nanooker »

I do not know what else I can do? With my dynv6 address I get to my router login.
By reach system, you mean the rooter, right?
Or my dietpi?
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Certbot failed with error code (1)

Post by Joulinar »

if you enter your dynv6 address you get the router login page? Then something is not correctly configured on your router. Usually you should be forward to your DietPi system
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
nanooker
Posts: 17
Joined: Sun Dec 06, 2020 7:41 pm

Re: Certbot failed with error code (1)

Post by nanooker »

yes then i get access to the router. I am going crazy
again from the beginning:
at dynv6 i enter my wan ip. e.g. 10.64.32.80
in the router i make a port forwarding of my static ip from
dietpi e.g. 192.168.200.6
in the rooter i create the dyndns of my hostname: user, password, server etc.
At dietpi I do not have to configure anything, except letsencrypt the entry of my hostname?
Now when I enter my dynv6 host in the browser I get the following page. See picture
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Certbot failed with error code (1)

Post by Joulinar »

looks like we are one step further. Using your DDNS you are able to reach your DietPi system from internet. You should be good to go with creating your certificates on DietPi system using dietpi-letsencrypt
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
nanooker
Posts: 17
Joined: Sun Dec 06, 2020 7:41 pm

Re: Certbot failed with error code (1)

Post by nanooker »

same error message.
I do not need to change anything in the letsencryp setting? I have a picture of this
in the certbot view in the topic the options of letsencrypt look different for me there is missing according to the picture
the option "autorenew
Last edited by nanooker on Sat Dec 12, 2020 6:09 pm, edited 1 time in total.
User avatar
Joulinar
Posts: 3131
Joined: Sat Nov 16, 2019 12:49 am

Re: Certbot failed with error code (1)

Post by Joulinar »

the picture is not up to date. Autorenew is done automatically. Nothing that needs to be set. The only thing I would recommend is to set redirect from HTTP to HTTPS. But all these settings have no influence in creating the certificate. Usually there is a log file created. If you are connected via SSH, you can scroll up once the blue screen is back. Ther you have some more information on the error.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply