Nextcloud OPcache Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Nextcloud OPcache

Post by novitibo »

strange. ls: cannot access?

ls -Al /etc/php/7.3/fpm/conf.d/99-dietpi.nextcloud.ini
ls: cannot access '/etc/php/7.3/fpm/conf.d/99-dietpi.nextcloud.ini': No such file or directory

but :o
root@DietPi:/etc/php/7.3/fpm/conf.d# ls

10-mysqlnd.ini 20-curl.ini 20-iconv.ini 20-phar.ini 20-sysvmsg.ini 20-zip.ini
10-opcache.ini 20-dom.ini 20-igbinary.ini 20-posix.ini 20-sysvsem.ini 98-dietpi.ini
10-pdo.ini 20-exif.ini 20-intl.ini 20-readline.ini 20-sysvshm.ini 99-dietpi-nextcloud.ini
15-xml.ini 20-fileinfo.ini 20-json.ini 20-redis.ini 20-tokenizer.ini
20-apcu.ini 20-ftp.ini 20-mbstring.ini 20-shmop.ini 20-wddx.ini
20-bcmath.ini 20-gd.ini 20-mysqli.ini 20-simplexml.ini 20-xmlreader.ini
20-calendar.ini 20-gettext.ini 20-pdo_mysql.ini 20-sockets.ini 20-xmlwriter.ini
20-ctype.ini 20-gmp.ini 20-pdo_sqlite.ini 20-sqlite3.ini 20-xsl.ini
User avatar
MichaIng
Site Admin
Posts: 2324
Joined: Sat Nov 18, 2017 6:21 pm

Re: Nextcloud OPcache

Post by MichaIng »

A typo, - instead of . ;). Okay so it is enabled.

Can you run and paste the output of: php -i | grep opcache
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Nextcloud OPcache

Post by novitibo »

ooo, typo also here :lol:

php -i | grep opcache
/etc/php/7.3/cli/conf.d/10-opcache.ini,
opcache.blacklist_filename => no value => no value
opcache.consistency_checks => 0 => 0
opcache.dups_fix => Off => Off
opcache.enable => On => On
opcache.enable_cli => Off => Off
opcache.enable_file_override => Off => Off
opcache.error_log => no value => no value
opcache.file_cache => no value => no value
opcache.file_cache_consistency_checks => On => On
opcache.file_cache_only => Off => Off
opcache.file_update_protection => 2 => 2
opcache.force_restart_timeout => 180 => 180
opcache.huge_code_pages => Off => Off
opcache.interned_strings_buffer => 8 => 8
opcache.lockfile_path => /tmp => /tmp
opcache.log_verbosity_level => 1 => 1
opcache.max_accelerated_files => 10000 => 10000
opcache.max_file_size => 0 => 0
opcache.max_wasted_percentage => 5 => 5
opcache.memory_consumption => 128 => 128
opcache.opt_debug_level => 0 => 0
opcache.optimization_level => 0x7FFEBFFF => 0x7FFEBFFF
opcache.preferred_memory_model => no value => no value
opcache.protect_memory => Off => Off
opcache.restrict_api => no value => no value
opcache.revalidate_freq => 1 => 1
opcache.revalidate_path => Off => Off
opcache.save_comments => On => On
opcache.use_cwd => On => On
opcache.validate_permission => Off => Off
opcache.validate_root => Off => Off
opcache.validate_timestamps => On => On
User avatar
MichaIng
Site Admin
Posts: 2324
Joined: Sat Nov 18, 2017 6:21 pm

Re: Nextcloud OPcache

Post by MichaIng »

So for CLI all settings are in fact as they should be. Only other idea, does something in Lighttpd override it?

Code: Select all

grep -r opcache /etc/lighttpd/
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Nextcloud OPcache

Post by novitibo »

grep -r opcache /etc/lighttpd/
/etc/lighttpd/conf-available/99-dietpi-nextcloud.conf: setenv.add-environment += ( "PHP_ADMIN_VALUE" => "opcache.memory_consumption=128" )
User avatar
MichaIng
Site Admin
Posts: 2324
Joined: Sat Nov 18, 2017 6:21 pm

Re: Nextcloud OPcache

Post by MichaIng »

Ah I already had that in mind, we added the memory consumption setting for the Nextcloud subdir only in the past, but that does not work as I thought that time, so we now add it PHP-wide.

Now if why if would cause the warning (as the value still is what it should be) but high change that solves it:

Code: Select all

sed -i '/opcache/d' /etc/lighttpd/conf-available/99-dietpi-nextcloud.conf
systemctl restart lighttpd
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Nextcloud OPcache

Post by novitibo »

We won! 8)

uf, it was a great journey, Tnx!!
User avatar
MichaIng
Site Admin
Posts: 2324
Joined: Sat Nov 18, 2017 6:21 pm

Re: Nextcloud OPcache

Post by MichaIng »

That directive is now actively patched our with next DietPi update :): https://github.com/MichaIng/DietPi/comm ... 986525feff
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Nextcloud OPcache

Post by novitibo »

+1 ;)
User avatar
novitibo
Posts: 87
Joined: Mon Feb 29, 2016 5:11 pm

Re: Nextcloud OPcache

Post by novitibo »

after upgrade to Buster the warning is back :?
just found out that folder /etc/php/7.3/fpm/conf.d/ contains 98-dietpi-nextcloud.ini and not 99-dietpi-nextcloud.ini

could this causing the issue?
Post Reply