Page 1 of 1

Problem with v6.32.2

Posted: Thu Sep 03, 2020 3:22 am
by aquliu
Hi guys, when I update to v6.32.2, I found that my temperature went wrong. It used to be wrong before v6.30 and fixed after this version. But it goes wrong this version again,(as below) So I came here to report this bug. My device is an intel NUC

Code: Select all

────────────────────────────────────────────────────
 DietPi v6.32.2 : 09:13 
 ─────────────────────────────────────────────────────
 - Device model : Native PC (x86_64)
 - CPU temp : -263200'C : -473728'F (Who put me in the freezer!)
 - LAN IP : 192.168.192.117 (wlan0)
 ─────────────────────────────────────────────────────

 DietPi Team     : MichaIng (lead), Daniel Knight (founder), Joulinar (support)
 Image           : DietPi Core Team (pre-image: Debian mini.iso)
 Web             : https://dietpi.com | https://twitter.com/DietPi_
 Patreon Legends : Bryce
 Donate          : https://dietpi.com/#donate
 DietPi Hosting  : Powered by https://myvirtualserver.com
By the way,I have another problem. I require a password when people use 'sudo' commond as non-root user,but now the situation is that when I 'sudo' as dietpi. it require no password.

Re: Problem with v6.32.2

Posted: Thu Sep 03, 2020 11:39 am
by Joulinar
Hi,

many thanks for your message. The temperature issue should have been fixed on DietPi 6.29. https://github.com/MichaIng/DietPi/issues/3412

Let me reopen the issue for the developer.

The 2nd "problem" should be fine. Because user dietpi is allowed to use sudo command without password. The setting is done on configuration file /etc/sudoers.d/dietpi

Code: Select all

root@DietPi3:~# cat /etc/sudoers.d/dietpi
dietpi ALL=NOPASSWD: ALL
root@DietPi3:~#

Re: Problem with v6.32.2

Posted: Thu Sep 03, 2020 12:32 pm
by MichaIng
Many thanks for reporting!

Yes indeed, applying some general coding quality standards broke the coretemp file path expansion in this case. I just fixed it: https://github.com/MichaIng/DietPi/comm ... 1fd93df6e6
In your /boot/dietpi/func/dietpi-globals you need to remove the double quotes around ${afp_temperature[@]} as in the commit, then reload the script:

Code: Select all

. /boot/dietpi/func/dietpi-globals
G_OBTAIN_CPU_TEMP

Re: Problem with v6.32.2

Posted: Thu Sep 03, 2020 5:12 pm
by aquliu
Thanks for your reply!