Page 1 of 1

https on nextcloud doesn't work..

Posted: Fri Oct 28, 2016 10:35 am
by fleaplc
I've a orange pi board running nextcloud. It works fine, then I'm trying to enable https:// but not work...
I followed this steps:
1-installed and configured no-ip (running dietpi-config I see for NoIP=Online / Active) that's fine
2-http://fuzon.co.uk/phpbb/viewtopic.php? ... art=10#p52 (install certbot and run dietpi-letsencrypt)
3- test my domain on https://www.ssllabs.com/ssltest/analyze.html (successfully)

but if I try to connect to my https://domain.org/nextcloud no way to get it!

any suggestion is appreciated

Re: https on nexcloud doesn't work..

Posted: Fri Oct 28, 2016 12:54 pm
by Fourdee
fleaplc wrote: 3- test my domain on https://www.ssllabs.com/ssltest/analyze.html (successfully)

but if I try to connect to my https://domain.org/nextcloud no way to get it!
Weird, if the SSL test comes back ok, it should be functional.

Does the default website work, eg: https://domain.org ?

Lets take a look at your settings, are you running Lighttpd or Apache2 webserver?

Re: https on nextcloud doesn't work..

Posted: Fri Oct 28, 2016 1:42 pm
by fleaplc
the default website is not a "website"... I mean, I'm using dietpi on orange pi pc in my home-lan. Than shared (DMZ) the orange pi to the internet.
With no-ip i get this host: fleacloud.hopto.org (seems works) (and I have a fixed public Ip from my isp)
I'm running apache2

Re: https on nextcloud doesn't work..

Posted: Sat Oct 29, 2016 7:33 pm
by Fourdee
fleaplc wrote:the default website is not a "website"... I mean, I'm using dietpi on orange pi pc in my home-lan. Than shared (DMZ) the orange pi to the internet.
With no-ip i get this host: fleacloud.hopto.org (seems works) (and I have a fixed public Ip from my isp)
I'm running apache2
Sorry, i meant the default index.htm page which gets installed by default.

Try connecting to your website without SSL to make sure its accessable externally: Then do the same with SSL: Also, can you paste/upload contents of the following files please:
  • /etc/apache2/apache2.conf
  • /etc/apache2/sites-available/* (eg: all files in this directory)