Page 1 of 1

Certbot error

Posted: Tue Jun 23, 2020 8:08 am
by Deleted User 7758
Hi all,
Trying to get some security on my Nextcloud instance. Installed Certbot and ran into this error
"CertBot failed with error code (1), please check its terminal output. Aborting... "

Can I get some help in finding the terminal output? This was all that was printed to the terminal before the error:

Code: Select all

DietPi-LetsEncrypt
─────────────────────────────────────────────────────
 Mode: Running CertBot

[  OK  ] DietPi-LetsEncrypt | Lighttpd webserver detected
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
Odroid XU3/XU4/MC1/HC1/HC2 (armv7l) | IP: 192.168.20.19  

Re: Certbot error

Posted: Tue Jun 23, 2020 10:15 am
by Joulinar
Hi,

many thanks for your message. Did you checked the log as indicated on your terminal output?

Code: Select all

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Re: Certbot error

Posted: Wed Jun 24, 2020 5:10 am
by Deleted User 7758

Code: Select all

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.
I'm going to need some additional help as this page viewtopic.php?f=8&t=5&p=1061#p1062 says
Simply enter the details and settings you require, then select Apply. Let's Encrypt is that simple!

Re: Certbot error

Posted: Wed Jun 24, 2020 7:46 pm
by Joulinar
Hi,

it is that easy. I created a small how-to sometime back. Maybe you like to have a look

viewtopic.php?p=25465#p25465