Netdata does not work Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
tec13
Posts: 13
Joined: Thu Apr 02, 2020 1:54 pm

Re: Netdata does not work

Post by tec13 »

42/5000
Thanks, it almost works!
I have this error:

Apr 06 13:18:10 DietPi netdata[1168]: 2020-04-06 13:18:10: netdata ERROR : MAIN
: child pid 1181 exited with code 7.


-----------------------------------
root@DietPi:~# systemctl status netdata.service
● netdata.service - netdata - Real-time performance monitoring
Loaded: loaded (/lib/systemd/system/netdata.service; disabled; vendor preset:
enabled)
Active: active (running) since Mon 2020-04-06 13:18:10 CEST; 1min
34s ago
Docs: man:netdata
file:///usr/share/doc/netdata/html/index.html
https://github.com/netdata/netdata
Main PID: 1168 (netdata)
Tasks: 17 (limit: 4915)
CGroup: /system.slice/netdata.service
├─1168 /usr/sbin/netdata -D
├─1226 bash /usr/lib/netdata/plugins.d/tc-qos-helper.sh 1
└─1231 /usr/lib/netdata/plugins.d/apps.plugin 1

Apr 06 13:18:10 DietPi systemd[1]: Started netdata - Real-time performance monit
oring.
Apr 06 13:18:10 DietPi netdata[1168]: /usr/lib/netdata/plugins.d/anonymous-stati
stics.sh 'START' '-' '-'
Apr 06 13:18:10 DietPi netdata[1168]: 2020-04-06 13:18:10: netdata INFO : MAIN
: /usr/lib/netdata/plugins.d/anonymous-statistics.sh 'START' '-' '-'
Apr 06 13:18:10 DietPi netdata[1168]: child pid 1181 exited with code 7.

Apr 06 13:18:10 DietPi netdata[1168]: 2020-04-06 13:18:10: netdata ERROR : MAIN
: child pid 1181 exited with code 7.
root@DietPi:~#
User avatar
Joulinar
Posts: 2312
Joined: Sat Nov 16, 2019 12:49 am

Re: Netdata does not work

Post by Joulinar »

yes I have seen it as well on my test system but did not find a way around yet. Did it impact your system? are you able to access Netdata?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
tec13
Posts: 13
Joined: Thu Apr 02, 2020 1:54 pm

Re: Netdata does not work

Post by tec13 »

Great, it works !!! :D
Thanks!

I had to edit the file /etc/netdata/netdata.conf and change the line bind socket to IP = 127.0.0.1 to match the local network IP
User avatar
Joulinar
Posts: 2312
Joined: Sat Nov 16, 2019 12:49 am

Re: Netdata does not work

Post by Joulinar »

hm strange, because the netdata.conf file was the original one that was created right after first installation. But anyway it's working now.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Deleted User 7758

Re: Netdata does not work

Post by Deleted User 7758 »

I also had some issues this evening.
Seems the executable wasn't installed until i re-installed as per posts on page 1 and then I did not get working net data until I followed tec13 and changed the bind address to local server ip.
User avatar
Joulinar
Posts: 2312
Joined: Sat Nov 16, 2019 12:49 am

Re: Netdata does not work

Post by Joulinar »

I guess you are on Debian Stretch as well. On Buster this should not happen. At least that how it was on my tests
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Deleted User 7758

Re: Netdata does not work

Post by Deleted User 7758 »

I'm on DietPi
User avatar
Joulinar
Posts: 2312
Joined: Sat Nov 16, 2019 12:49 am

Re: Netdata does not work

Post by Joulinar »

8) weil DietPi is not an own OS. It is a set of script on top of a Debian base image. For example on Raspberry Pi the base image is Raspbian Lite. For other boards it's Armbian. Stretch and Baster are the Debian versions. Where Buster is the current version and Stretch the one before.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Deleted User 7758

Re: Netdata does not work

Post by Deleted User 7758 »

ok, I kinda knew that DietPi was a version of Debian. Anyway, mine was downloaded a week ago - the version for Odroid HC1
User avatar
Joulinar
Posts: 2312
Joined: Sat Nov 16, 2019 12:49 am

Re: Netdata does not work

Post by Joulinar »

Can you let me know the image you downloaded exactly? The current official one is based on Debian Stretch but there was already a new Debian Buster image created. It still has the testing flag but should work already. On Buster the issue should be gone.

https://github.com/MichaIng/DietPi/issues/2979

https://dietpi.com/downloads/testing/Di ... -Buster.7z
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply