Page 2 of 2

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Thu Feb 06, 2020 5:47 am
by MrGlasspoole
The latest also does not work. Black screen...
I reported it on GitHub.

So i tried Jessie from here: https://dietpi.com/downloads/images/legacy/
But after login i get:

Code: Select all

-bash: /DietPi/dietpi/login: No such file or directory
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory
and nothing works.

I have different boards (RPi 3, RPi Zero, BananaPi, C2) and this C1+ is the first one where i have this problems.

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Thu Feb 06, 2020 12:22 pm
by Joulinar
Jessie is not supported by DietPi anymore.

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Thu Feb 06, 2020 6:05 pm
by MrGlasspoole
But back then it was a working image?

-----------------------------------------------------------
DietPi Odroid C1 Buster - Downloaded 2020.02.06
-----------------------------------------------------------
Black screen and the blue LED is just always on

-----------------------------------------------------------
DietPi_v6.22_OdroidC1-ARMv7-Stretch
-----------------------------------------------------------
Black screen and blue LED constantly flashing
Not showing up in DHCP

-----------------------------------------------------------
DietPi_v6.0_OdroidC1-ARMv7-Jessie
-----------------------------------------------------------
After login:
-bash: /DietPi/dietpi/login: No such file or directory
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory

---------------------------------------------------------------------
Armbian_5.38_Odroidc1_Debian_jessie_default_3.10.107
---------------------------------------------------------------------
Works

--------------------------------------------------------------------------
Hardkernle Ubuntu-18.04.3-3.10-minimal-odroid-c1-20190923
--------------------------------------------------------------------------
Works

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Fri Feb 07, 2020 10:14 pm
by MichaIng
Okay, so just to focus testing/debugging:
- Debian Jessie it nothing we further support, hence I'm not going to digging into this, as long as it is not an old system that was running Jessie since when it was still supported.
- Kernel 3.10 images is not something we can use, because Debian Stretch basically requires Linux 3.16, and we want Debian Buster. This was also the reason why we moved from Meverics old Jessie image to Armbian as basis.
- The current v6.22 Stretch image is up for a long time. So actually that should boot fine. Although I have no detailed download statistics but definitely would expect some more reports if that failed in many other cases as well.
- However we want Buster where possible, hence I would like to concentrate on the current Armbian Buster based image.

@spanx20
For you the current stable (Stretch) image works on SDcard? It is the same with the new Buster-based beta image?
I see now the following: https://www.armbian.com/odroid-c1/
Kernel Issues
  • eMMC not supported
Hence it is sad, but we have no acceptable chance to get this working currently. And I also don't believe that Armbian is going to invest much time to fix things for this device, since it is not even listed in their official devices list: https://www.armbian.com/download/?tx_maker=hardkernel

@MrGlasspoole
Found the thread where we discussed the Stretch image that time: https://github.com/MichaIng/DietPi/issues/2561
So yeah, no HDMI output indeed, and that seems to have not changed until now :(. Also the issue is mentioned that reboot hangs with blue light and needs unplug cycle. This sounds like your boot issue, is it probably actually booting but then hangs on some initial reboot? Although there is no automated reboot done on current DietPi, as long as one does not enabled automated firstrun installs... And also this issue has been crossed through on Armbian product page :?.

So what I derive from that is that we need to make the known issues clear on our download page as well. And I'll verify that correct serial console is enabled + local getty disabled, since no point in having this without video output.

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Mon Feb 17, 2020 11:48 am
by MrGlasspoole
I give up on the C1. No unplug cycle or something else does work.

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Mon Feb 17, 2020 12:21 pm
by MichaIng
@MrGlasspoole
You mean it does not boot up at all after reboot + plug off + plug on?

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Tue Feb 18, 2020 4:52 pm
by MrGlasspoole
Yes

Re: Latest odroid C1 image 6.22 doesn't work!

Posted: Fri Feb 21, 2020 11:29 am
by MichaIng
Okay only thing I can suggest for now is trying it with the Armbian image and see if the issue is the same after doing all kernel/firmware upgrades: apt update && apt full-upgrade