Page 1 of 1

No dietpi software works

Posted: Thu Jan 16, 2020 1:32 pm
by Jensnet
Hello. None of the dietpi software works after the latest upgrade. I get the error that a ping request to one.one.one.one fails. I can ping it from the commandline. The same with a fresh install the startup guide fails with the same error. Hardware pine64 and rockpro64

Re: No dietpi software works

Posted: Thu Jan 16, 2020 1:35 pm
by Joulinar
Hi,
Many thanks for your report.

Pls can you disable IPv6 within dietpi-config if not used

Re: No dietpi software works

Posted: Thu Jan 16, 2020 2:55 pm
by Jensnet
I cant access dietpi-config. It tells me to reboot and after the reboot the same

Re: No dietpi software works

Posted: Thu Jan 16, 2020 3:07 pm
by Joulinar
Are you able to login via SSH? What happen if you are login? Is that an empty installation or do you have installed something already?

Re: No dietpi software works

Posted: Thu Jan 16, 2020 4:17 pm
by Jensnet
I log in with ssh and it is a fresh install

Re: No dietpi software works

Posted: Thu Jan 16, 2020 4:20 pm
by Joulinar
Once login, can you open dietpi-config ? Or is it doing anything? If you are not mind, you could start from scratch and re-image your SD card and can deactivate IPv6 already before you plug your SD card into your SBC by changing some config settings right after SD card creation.

Re: No dietpi software works

Posted: Thu Jan 16, 2020 4:33 pm
by Jensnet
I cant access dietpi-config before the first start script runs

Re: No dietpi software works

Posted: Thu Jan 16, 2020 4:35 pm
by Joulinar
Ok than let's start from scratch. It will be the easiest way. Will type some small how-to later on as currently I'm at Vienna Airport and short before flight.

Re: No dietpi software works

Posted: Thu Jan 16, 2020 4:39 pm
by Jensnet
Can you send it to me?

Re: No dietpi software works

Posted: Fri Jan 17, 2020 11:27 am
by Joulinar
sorry for the dealy.

IPv6 can be disabled before initial boot. Once you have flashed your SD card, just remove it, wait a second and put it back to your desktop computer. You should have mounted an additional drive called boot. There your have the config files and you could adjust settings that will be applied initially. Locate the file called dietpi.txt and open it with a text editor and search for the following line:

Code: Select all

# IPv6
CONFIG_ENABLE_IPV6=0
putting it to 0 will disable IPv6. Hope it will fix your issue. If not you could adjust DNS domain check on your needs.

Code: Select all

# - Domain to ping when checking DNS resolver. Default: one.one.one.one (Cloudflare DNS domain, see above)
CONFIG_CHECK_DNS_DOMAIN=one.one.one.one
In addition we updated the Getting started guide (step 4) accordingly.

viewtopic.php?p=9#p9