Page 1 of 1

Some Bugs found in Intel NUCi5BNH

Posted: Thu Jan 09, 2020 12:31 pm
by aquliu
Hi guys, I’m sorry to disturb you. But recently I encountered some problems about dietpi in my Intel NUCi5BNH (Whose cpu is i5-7260u), I tried to search the github and the forums but in vain.
I tried install the dietpi(x64 UEFI) in Intel NUC, It works with all the hardwares (includes WiFi&Card Reader),But there’re something wrong with the CPU. Firstly the CPU temperature shows an extremely low number (Such as -263200’C),When I run [sudo cpu], It shows like these:

DietPi CPU Info
Use dietpi-config to change CPU / performance options
Architecture | x86_64
Temperature | -263200'C : -473728'F (Who put me in the freezer!)
Governor | performance

Current Freq Min Freq Max Freq
CPU0 | 3400 MHz 400 MHz 3400 MHz
CPU1 | 3400 MHz 400 MHz 3400 MHz
CPU2 | 3400 MHz 400 MHz 3400 MHz
CPU3 | 3399 MHz 400 MHz 3400 MHz

[ INFO ] DietPi-CPU_info | CPU current frequency, may be affected by this script, due to the processing required to run it.

What’s more, when comes into cpu performance settings, It’s lacks of the choice “on demands”. I can just run the NUC at maximum frequency. I tried to upgrade the Linux kernel from 4.19 to 5.3.0, but nothing changed.

The last, when I power on the NUC, it cost more than 5 minutes in postboot step before enter the system. Is it abnormal ?

Thanks for contributing so much time in an amazing system. I’ll be grateful for every word you reply.

Re: Some Bugs found in Intel NUCi5BNH

Posted: Thu Jan 09, 2020 12:42 pm
by MichaIng
Many thanks for your report.

About the CPU temperature, I guess it's this issue:

If postboot takes very long, this is most likely due to a hanging service start, which each have a timeout of 90 seconds. You could test by restarting all services and see if one takes very long or even fails: dietpi-services restart

Re: Some Bugs found in Intel NUCi5BNH

Posted: Thu Jan 09, 2020 12:58 pm
by aquliu
So grateful for your amazing replying speed!

I read the link you post, Thankful for your hardworking on this! Be willing to do everything what I can test for this!

As for the adjustment of cpu performance, Is there any possibility for the i5-7260u to perform “on demand” rather than “performance” ? Any more drivers need to be installed or specifical Linux kernel is needed?

Re: Some Bugs found in Intel NUCi5BNH

Posted: Thu Jan 09, 2020 1:59 pm
by aquliu

I just tried edit the type of cpu performance from "performance" to "ondemand" in /DietPi/dietpi.txt, then reboot, but nothing changed.
In case that I get wrong number of frequency, I install the netdata and read the cpu freq, It's still at the max freq.

I tried the other command got from another tread in forums:
[cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state]
no such file or folder.

There is still a good news, when I turns the turbo option on, it works properly at its turbo freq, but static.

Is the cpu can only run at the static freq at current version?

Re: Some Bugs found in Intel NUCi5BNH

Posted: Thu Jan 09, 2020 5:12 pm
by aquliu
I just found a theory about this condition: ... state.html

This is because your system is using the new driver called intel_pstate. There are only two governors available when using this driver: powersave and performance.
The userspace governor is only available with the older acpi-cpufreq driver (which will be automatically used if you disable intel_pstate at boot time; you then set the governor/frequency with cpupower):
disable the current driver: add intel_pstate=disable to your kernel boot line
boot, then load the userspace module: modprobe cpufreq_userspace
set the governor: cpupower frequency-set --governor userspace
set the frequency: cpupower --cpu all frequency-set --freq 800MHz

I don't know wheather it will benifits from this because maybe the newer is better ?

Have one any idea about this ? Should I try this way or leave the cpu at Max freq ?