Software Won't Install Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Deleted User 612

Software Won't Install

Post by Deleted User 612 »

I tried to install Fail2Ban and received an error that I unfortunately didn't capture, but was I think a lot like the apt-get errors in this post ... 1026#p1023

Fail2Ban seemed to install anyway though and reboot. I then couldn't login via SSH repeatedly getting 'Access Denied'. I thought maybe Fail2Ban had blocked my IP or something strange like that. I then manually reset my Pi and everything was back to normal, but Fail2Ban wasn't installed.

I then tried to reinstall Fail2Ban and got this error:

Code: Select all

 Mode: Update & upgrade APT
 Please wait...

 [Info] Waiting for apt-get update to finish: Please wait...
 [Ok] Completed

Hit jessie InRelease
Ign  InRelease
Hit  Release.gpg
Hit jessie/main armhf Packages
Hit  Release
Hit jessie InRelease
Hit jessie/contrib armhf Packages
Hit jessie/non-free armhf Packages
Hit jessie/rpi armhf Packages
Hit  Packages
Hit jessie/main armhf Packages
Hit jessie/ui armhf Packages
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/ui Translation-en_GB
Ign  Translation-en_GB
Ign jessie/ui Translation-en
Ign  Translation-en
Ign jessie/contrib Translation-en_GB
Ign jessie/contrib Translation-en
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en_GB
Ign jessie/non-free Translation-en
Ign jessie/rpi Translation-en_GB
Ign jessie/rpi Translation-en
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
 [Info] Running apt simulation to check for errors, please wait...
 [Failed] Apt simulation | An issue has occured

 [Info] The apt cache may be corrupt, or you have held broken pacakages. DietPi-Software will now exit.

 [Info] Please try:
 [Info] - Fixing apt package errors with 'apt-get install -f'
 [Info] - Changing '/etc/apt/sources.list' to another repo mirror.
 [Info] - Clear and refresh apt '/DietPi/dietpi/dietpi-apt-get_update 2'
I then ran the following commands:

Code: Select all

dpkg --configure -a
apt-get install -f
/DietPi/dietpi/dietpi-apt-get_update 2
Then reinstalled Fail2Ban (dietpi-software) and the installation went normally, except that after reboot, there is no sign of Fail2Ban at all, still.
Attempting to reinstall again I receive the same error as pasted above and the cycle repeats.

I tried installing using apt-get install fail2ban and exactly the same problem. It is also happening with other software, I tried installing Pi-Hole and the same problem occurred. Tested using Virtual Box and it worked fine.

Any help greatly appreciated, as I have no idea what the problem might be :(
Last edited by Deleted User 612 on Tue Sep 06, 2016 7:14 pm, edited 1 time in total.
Deleted User 612

Re: Software Won't Insatll

Post by Deleted User 612 »

Update: I think what's happening is that every time I reboot I reset to a certain point each time, I tried dietpi-update and although it updated, it reverted back to the previous version on reboot. Also tried editing /etc/www/index.html and all changes lost on reboot :(

Any ideas?

Maybe the SD card file system got corrupted when I manually reset the Pi?
User avatar
Site Admin
Posts: 2781
Joined: Tue Feb 06, 2007 1:36 pm

Re: Software Won't Insatll

Post by Fourdee »

Tin Minnow wrote:Also tried editing /etc/www/index.html and all changes lost on reboot
Hi Tim,

The only RAM mounts are /DietPi /var/log and /tmp. So for other directories that "reset" data, is very strange.

Could you please send me a bug report. It will allow me to check your installation and mounts. Please run the following:

Code: Select all

No need to fill out the document, simply reply with the unique reference code.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Deleted User 612

Re: Software Won't Install

Post by Deleted User 612 »

Hi Fourdee,

Yes indeed it was very strange. I ended up putting it down to a corrupt SD card after doing some more research. I needed to get back up and running quickly so reinstalled on a different SD and it is now working fine. But it is unfortunate, I would have liked to figure out what the problem was, it made no sense, I just couldn't permenantly write anywhere :?
Post Reply