Permisssions issue with sonarr, radarr, jackett etci

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Fun4stuff
Posts: 3
Joined: Fri Aug 23, 2019 9:29 pm

Permisssions issue with sonarr, radarr, jackett etci

Post by Fun4stuff » Fri Aug 23, 2019 9:36 pm

Sonarr and like programs our now unable to write programs to my NAS. Things were working fine up until a week or two ago- i just noticed them.

I am able to go into drive manager and successfully test read and write from these network drives though. I can also create files
On my NAS from the command
line prompt using nano. I can do this even from the sonarr user.

I’m not sure what changed in the last week or to to make this happen. I have another pi running rasibian (notndiet) and set up sonarr and the other programs and it works fine so i don’t think it’s a NAS problem.

User avatar
MichaIng
Legend
Posts: 1638
Joined: Sat Nov 18, 2017 5:21 pm

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by MichaIng » Sat Aug 24, 2019 5:08 pm

@Fun4stuff
By "write programs" you mean downloading/sorting files to the NAS?
Is it probably the downloader itself that fails, and not Sonarr or Radarr?
Which downloader did you configure?

Generally, to allow R/W access throughout all related programs, please set NAS permissions to (or mount as) user:group dietpi:dietpi and 775 mode. All software that require userdata access run as their own user which is added to the dietpi group. So they have R/W access to all dirs/files own by dietpi group and with 77X permissions mode.

And generally error logs (/var/log/sonarr and /var/log/radarr or systemctl status sonarr and systemctl status radarr) are helpful to derive what exactly failed.

And since it is a known issue with Jackett, if not yet done, please disable its internal auto updater. It breaks Jackett, a still not resolved external bug that affects all instances that are started via systemd unit.

Diji23
Posts: 2
Joined: Sat Aug 24, 2019 8:46 pm

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by Diji23 » Sat Aug 24, 2019 8:57 pm

I'm having this exact problem and nothing seem to work ; reinstall, format, clean apt etc. I also though it was permission issues at first but then I found this thread this morning while googling for similar problems/error codes;

https://forums.sonarr.tv/t/permission-i ... e/22876/10
https://www.reddit.com/r/sonarr/comment ... _all_of_a/
https://forums.sonarr.tv/t/permission-d ... tion/22967


So, problem seems to be a problem Mono 6.0 and cifs... the 'fix' in the thread says :

Code: Select all

Thanks for the details. I can confirm that a rollback to Mono 5 fixed this issue.

For anyone affected by the upgrade, here is what I did to roll back to 5.20.1.34 (current Mono 5 snapshot) on Ubuntu 18.04:

Edit your /etc/apt/sources.list.d/mono-official-stable.list and change:

deb https://download.mono-project.com/repo/ubuntu stable-bionic main

to:

deb https://download.mono-project.com/repo/ubuntu stable-bionic/snapshots/5.20.1.34 main

That will pin it to version 5.20.1.34

Basic Steps to Downgrade:

sudo apt-get remove mono-runtime

Edit your mono-official-stable.list file per above

sudo apt-get update
sudo apt-get install mono-runtime
sudo apt-get install sonarr

More details on the mono website:

http://www.mono-project.com/docs/getting-started/install/linux/#accessing-older-releases 6

Reference for the versions available:

http://download.mono-project.com/repo/debian/pool/main/m/mono/ 7
However, im not familliar with commands/linux and I'm having signatures problems all over the place when I reproduce these exact same steps on dietpi.

Perhaps someone with more knowledge could help us apply it to Dietpi ?

Fun4stuff
Posts: 3
Joined: Fri Aug 23, 2019 9:29 pm

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by Fun4stuff » Mon Aug 26, 2019 1:07 am

Thanks all! I do suspect it’s a problem with mono. Everything was working up until recently. I had not changed how the network drives were mounted.

To clarify the problem I’m having: i have nzbget running on my nas. Sonarr/radarr/jackett run on dietpi. After the media is download on nzbget i get an error message in sonarr/radarr saying it could not write to my NAS (could not move and rename downloaded file).

For now, i moved sonarr and radarr to my other pi that is not running diet pi and things are working fine. Limited on time this week due to work- maybe I’ll try rolling back mono next weekend!

Diji23
Posts: 2
Joined: Sat Aug 24, 2019 8:46 pm

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by Diji23 » Mon Aug 26, 2019 11:10 am

Thank for update Fun4Stuff,

Care to tell me which version/distro your other PI is running ? I might move away from dsietpi until it is fixed.

Fun4stuff
Posts: 3
Joined: Fri Aug 23, 2019 9:29 pm

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by Fun4stuff » Mon Aug 26, 2019 3:48 pm

It’s running raspbian. I haven’t updated it in a few months.

User avatar
MichaIng
Legend
Posts: 1638
Joined: Sat Nov 18, 2017 5:21 pm

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by MichaIng » Mon Aug 26, 2019 4:32 pm

@Diji23 @Fun4stuff
If you run a Buster image, can you try to install the Mono version from new Buster branch? This is available since two weeks ago, finally:

Code: Select all

dietpi-services stop
sed -i 's/stretch/buster/' /etc/apt/sources.list.d/mono-xamarin.list
G_AGUP
G_AGI mono-runtime mono-complete nzbdrone
dietpi-services start
As well try to update Radarr to development branch: Settings -> General (Show Advanced Settings) -> Updates -> Branch

If as well the lasted versions do not include a fix, then indeed the Mono downgrade seems to be the only possibility.

The snapshots feature should work:

Code: Select all

echo 'deb https://download.mono-project.com/repo/debian/ stretch/snapshots/5.20 main' > /etc/apt/sources.list.d/mono-xamarin.list
G_AGUP
G_AGI --allow-downgrades --reinstall mono-runtime mono-complete

boten
Posts: 1
Joined: Sat Aug 31, 2019 7:21 am

Re: Permisssions issue with sonarr, radarr, jackett etci

Post by boten » Sat Aug 31, 2019 7:25 am

Do I have to run more commands than those 3 if I want to downgrade? Fairly new to this and nothing happens. Am I supposed to execute some install command atterwards?

Post Reply