Page 1 of 1

Unable to find suitable address.

Posted: Thu Aug 15, 2019 6:49 am
by Sirrus_Rider
Hi All,

New Rasberry Pi 4 owner and I'm trying to set up a next cloud service on it. I got everything running, but I can't seem to map any network drives.

I've got a Drobo 5n that I'd like to map to and I run Diet-pi-Drive_Manager. I'm able to map it no problem, but when I reboot the system so Nextcloud will pick up the drive I get:

Aug 15 05:44:26 Owncloud systemd[1]: Mounting /mnt/samba...
Aug 15 05:44:33 Owncloud mount[525]: Unable to find suitable address.
Aug 15 05:44:33 Owncloud systemd[1]: mnt-samba.mount: Mount process exited, code=exited, status=32/n/a
Aug 15 05:44:33 Owncloud systemd[1]: mnt-samba.mount: Failed with result 'exit-code'.
Aug 15 05:44:33 Owncloud systemd[1]: Failed to mount /mn

If I run drive manger and refresh it then finds the mounts, but again without a restart nextcloud won't pick them up.

Any ideas on what I should look at or do??

Thanks!

Re: Unable to find suitable address.

Posted: Mon Aug 19, 2019 8:05 pm
by MichaIng
Hmm, strange, it looks like the share is attempted to being mounted too early, when network has not yet fully been setup. In journalctl logs, can you check the order of network services/targets and the network mount?

As well strange is that even if the above is true, dietpi-boot calls mount -a again after our internal network check, that includes checking for a default gateway which is a further prove for network connection being full set up. So even if systemd does not manage to mount the drive in the first place, dietpi-boot should do. Can you paste:
cat /var/tmp/dietpi/logs/dietpi-boot.log