Getting g_ether to work

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Posts: 1
Joined: Wed Aug 14, 2019 11:12 pm

Getting g_ether to work

Post by DennyCrane » Wed Aug 14, 2019 11:18 pm

I was using a Mint 19.2 VM for testing against a device that makes an ethernet over USB gadget. In Mint, it just worked and I didn't have to do anything, but instability of the VM usb passthru made it impossible to properly test the gadget.

So I figured my Rock64 running dietpi would cut out the VM side of things, but unfortunately it didn't 'just work'. I was advised by a colleague to "modprobe g_ether", after which I should see usb0 interface appear. However, when I run this command on the dietpi, I get:
modprobe: FATAL: Module g_ether not found in directory /lib/modules/4.4.182-rockchip64
Does anyone know if there is a workaround to getting g_ether working, or just a limitation of dietpi/rock64 and I need a full blown distro?

Thanks in advance!

Post Reply