Page 1 of 1

Troubles adding shared drive

Posted: Mon Jul 22, 2019 3:06 am
by nuentes
I'm running DietPi through VirtualBox installed in Lubuntu. I've been having a hell of a time getting shares added to the DietPi VM. I've tried everything I can think of, and have failed every step of the way.

First, I wanted to use USB. Unfortunately, my system has 10 different USB HDDs, and Virtualbox had a limit of 7 or 8. Then I tried using VirtualBox's shared drive function, hoping to just share the entire /media/ folder. I followed every guide I could find. I ran the guest addons ISO in Dietpi and attempted to install. After this, my DietPi boot time went from about 30 seconds to around 5-8minutes, as I assume something went wrong. And then no folder I ever tried to share ever became available. And within dietpi, I did add the root user to the vboxsf group. Still no luck. Ok, so I removed the guest addons (boot time went back to normal!) and then tried to share the folder with NFS. I used known working NFS commands that I had configured on my old server that I took offline (2 days ago), The command added the NFS user to UID 1000 and GID 1000, which are indeed the appropriate user/group IDs that have ownership of those files/folders within Lubuntu, and yet I was still getting permissions errors when trying to access the NFS folder.

My goal with all of this is to re-create the NAS/media download server I had been running in Ubuntu Mate (which I could still boot whenever I want since that drive is still untouched). I just wanted to fundamentally change how I run everything and do all tasks through VMs with a very vanilla base-OS (Lubuntu). I want to share the HDDs connected out via both NFS and samba. That's the goal. I'd rather not make my Vanilla OS essentially run as a file server so that DietPi can ALSO run as a file server. Doesn't seem to make sense.

If you need more details about anything in particular, please feel free to ask. Very sorry if I provide bad details, I'm just dealing with high levels of frustration as I've been working on getting my server back to a working state for about 2 days now.

Re: Troubles adding shared drive

Posted: Wed Jul 24, 2019 2:59 pm
by nuentes

I'll rephrase and summarize: When using VirtualBox, what is the suggested way to share large amounts of storage from the host to DietPi? Are the VirtualBox Guest Addons supposed to work? Have they been tested by anybody as working? Is this user error, or did I discover a bug? Because it appears the Guest Addons won't install correctly.

Should I try installing a Debian image, then install the Guest Addons, and then convert the image to a DietPi system and see if the Guest Addons continue to work? Or should I simply share the files from the host with NFS?