Page 1 of 1

Dietpi-Services [Failed] Samba

Posted: Thu Aug 18, 2016 1:06 pm
by gark81
Hi all.

I'm setting a DietPi on a RPi2
I installed NoIP, transmission,netdata, LEAP, ProFTPD, OpenVPN, but now i'm trying to install Samba server near FTP server, but when RPi reboots, i get :
DietPi-Services
...
[Failed] Samba


I connect by ssh, and i get this
root@DietPi:~# service samba status
● samba.service
Loaded: masked (/dev/null)
Active: inactive (dead)
root@DietPi:~# service samba start
Failed to start samba.service: Unit samba.service is masked.

I'm searching for this issue and i couldn't find anything.

Is there a problem to install Samba and FTP at the same time?

i wish to use FTP to access at RPi from outdoor, and samba only in local (with complete access to " / " )

Re: Dietpi-Services [Failed] Samba

Posted: Thu Aug 18, 2016 8:01 pm
by Fourdee
gark81 wrote:Hi all.

DietPi-Services
...
[Failed] Samba
Hi,

Thanks for letting us know.

We have a known issue where, if the user has smbclient package installed, DietPi-Services will attempt to start the samba server: https://github.com/Fourdee/DietPi/issues/451.
i wish to use FTP to access at RPi from outdoor, and samba only in local (with complete access to " / " )
If your running DietPi v128 or higher, you can run the following command to install both Samba server and Proftpd through DietPi-Software:

Code: Select all

dietpi-software install 96 94
You can check to see what software is currently installed with:

Code: Select all

dietpi-software list | grep =2

Re: Dietpi-Services [Failed] Samba

Posted: Fri Aug 19, 2016 6:07 pm
by gark81
Fourdee wrote:
gark81 wrote:Hi all.

DietPi-Services
...
[Failed] Samba
Hi,

Thanks for letting us know.

We have a known issue where, if the user has smbclient package installed, DietPi-Services will attempt to start the samba server: https://github.com/Fourdee/DietPi/issues/451.
Thanks, but i haven't installed smbclient, i only install samba server and ftp server.

Re: Dietpi-Services [Failed] Samba

Posted: Sat Aug 20, 2016 9:00 pm
by 4bob
Hi,

Fourdee is trying to tell you that there is a bug with his software installer;
Maybe in your case smbclient being picked up as samba server!

with

Code: Select all

dpkg -l |grep samba 
you can verify that all samba server packages are installed. (one is needed for client and server)
root@DietPi:~# service samba status
● samba.service
Loaded: masked (/dev/null)
Active: inactive (dead)
/etc/init.d/samba wrapper script doesn't work well with systemd
check the service with

Code: Select all

/etc/init.d/samba status 
and if needed

Code: Select all

/etc/init.d/samba start 
That should do ;)

Bob