Page 1 of 1

Please help me recover!

Posted: Fri May 17, 2019 4:20 pm
by brtravel
I have DietPi running on an Odroid HC2 (xu4) as a Plex server and a few other functions. It's been working trouble-free for months, and I have many configurations that I really don't want to lose. I boot from the microSD, and I've changed the /mnt to the attached HDD. I last updated the software a few weeks ago (6.23?). I don't think I ever created a proper dietpi-backup.


So today, with the drive accessed through Samba, I ran on my computer a scan on the DietPi/HC2 drive and an external drive (using FreeFIleSync) to compare my DietPi/HC2 media folder with a backup of media I keep on the external. Not long after I noticed that my Plex clients couldn't load any media, so I thought something crashed with Plex Media Server. I SSH'd into the DietPi/HC2 and sent the reboot command.

And that's the last I ever heard from her...
:cry:

Now, the LEDs appear normal with activity on the ethernet light and the blue 'heartbeat' LED giving its double blink. I can't SSH into the device (and no hdmi on this board), and looking in my router admin I see that it is not seen as connected to the network. I tried flashing DietPi to a different microSD, and that booted up fine, is visible to the router, and I can SSH to it, so it doesn't seem to be a network or hardware issue. What could be 'corrupted' on that microSD that causes it to no longer show up in the network?

So is there anything I can try to get back the installation I had yesterday?

Re: Please help me recover!

Posted: Fri May 17, 2019 5:25 pm
by waulu13
Doesn't it have a UART port to access to a Linux console?

Re: Please help me recover!

Posted: Sat May 18, 2019 5:02 am
by brtravel
Oookay, nevermind ???

I left it plugged in, but didn't do anything more, for maybe 12 hours, and I just noticed it's all working again! Samba, Plex, other software.

Weird.

Thanks for listening.

Re: Please help me recover!

Posted: Sun May 26, 2019 10:34 pm
by MichaIng
@brtravel
Could you please paste: dmesg | grep random

Re: Please help me recover!

Posted: Mon May 27, 2019 9:17 am
by brtravel
It's all greek to me :P

Code: Select all

[email protected]:~# dmesg | grep random
[    0.000000] random: get_random_bytes called from start_kernel+0x8c/0x420 with crng_init=0
[    0.671827] random: fast init done
[   15.980890] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[   15.986858] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[   15.990971] random: udevadm: uninitialized urandom read (16 bytes read)
[   22.483981] random: crng init done
[   22.485923] random: 7 urandom warning(s) missed due to ratelimiting

Re: Please help me recover!

Posted: Mon May 27, 2019 3:10 pm
by MichaIng
@brtravel
Okay since the messages are only 20s after boot, most likely empty entropy pool was not the issue. However if you face either long boot times or hanging service (re)starts, then run the command again and see if some messages like this appear with a larger number than ~30, so later after boot. If that is the case, then the following might help: G_AGI haveged
This is a daemon that assures a filled entropy pool, so the pool to get random chars from. "uninitialized urandom read"/"urandom warning(s)" means that some process tried to get random chars from /dev/urandom, but it was simply not possible because there were not enough hardware events that create this on boot. This is especially an issue on headless devices with not much hardware components attached/enabled.