Page 1 of 1

libc6 version to be upgrade ??

Posted: Thu May 16, 2019 11:13 am
by Facel
The libc6 version is 2.24 on the Dietpi 6.23.3 version .

Is it possible to upgrade libc6 version to have a the 2.28 (or above) ?

In case of a positive answer : what should I do ?

thanks

PS : the libc6 version has been release on 2016-08-05 !!! quite old is'nt it ?

Re: libc6 version to be upgrade ??

Posted: Fri May 17, 2019 12:49 pm
by MichaIng
@Facel
This is the negative aspect of Debian: It's package repository is known to be very stable, but since the major versions are frozen, those become outdated more and more. There are ways of course to add Buster (the next stable Debian release, expected to be released this summer, currently in testing repo) or backport repos, but actually I would no recommend if you have any other chance. Mixing repositories currently causes several issues on ARMv6 devices, where we were forced to add the Buster repo for PHP7.3 install.

Re: libc6 version to be upgrade ??

Posted: Fri May 17, 2019 1:34 pm
by Facel
Thank you for your explanation.
I will not go for any Buster adventure ...

When I run an apt-get upgrade command does it upgrade properly the packages ?

does the dietpi-ugrade provide the same result as the apt-get upgrade command ?

Re: libc6 version to be upgrade ??

Posted: Sun May 19, 2019 11:29 pm
by MichaIng
@Facel
Jep, apt upgrade includes libc6 updates to the most current that is available in your repos (Stretch then). dietpi-update includes the APT upgrade as well.