Page 1 of 1

Emby Install Error

Posted: Tue Apr 02, 2019 4:13 am
by canabino
I had emby server on my dietpi for a few months.
Yesterday after a reboot I couldn't access Emby server.
I ran htop and saw none of the emby services running.
I tried reinstalling with dietpi-software reinstall 41 but got an error
I then uninstalled Emby and tried to install it again through dietpi-software
but got the following error.
Capture.PNG
I tried searching online but got no results
What should I do?

Re: Emby Install Error

Posted: Tue Apr 02, 2019 10:58 am
by canabino
I tried the following.
MichaIng wrote: Mon Apr 01, 2019 8:51 pm Hi and thanks for your report.

Yeah indeed this happens since the latest Emby release is only available for Windows. We reworked the installer to use a last known fallback URL if the latest release does not contain one for Debian: https://github.com/MichaIng/DietPi/comm ... 84a718aedd

Please do the following:

Code: Select all

sed -i 's#"$(curl -s "$INSTALL_URL_ADDRESS" | grep -m1 "browser_download_url.*emby-server-deb_.*_$arch\\.deb" | cut -d \\" -f 4)"#"https://github.com/MediaBrowser/Emby.Releases/releases/download/4.0.2.0/emby-server-deb_4.0.2.0_$arch.deb"#' /DietPi/dietpi/dietpi-software
/DietPi/dietpi/software install 41 # to rerun the Emby install
But still get dpkg error. In dietpi-software it shows that Emby is installed but I checked with htop, it is not running.
DPkg Error.PNG

Re: Emby Install Error

Posted: Thu Apr 04, 2019 4:23 pm
by MichaIng
Solved as of the other thread.