Page 1 of 1

Raspi Model A+ Memory Bug

Posted: Fri Jan 04, 2019 6:32 pm
by megusta
Hey guys,
you've done a great job! In a half hour I've got all I need.
It works fine with my Pi Zero, but not with my Model A+.

I found a Bug, the configuration isn't the same as Model 3B+. Model A+ has only 512MB memory. So if I split gpu and memory, I got the configuration of Model 3B+ with 1024MB memory.

And if I install desktop environment, I get heavily performance problem

Re: Raspi Model A+ Memory Bug

Posted: Tue Jan 15, 2019 6:40 pm
by MichaIng
@megusta
When you change GPU mem split via dietpi-config, there are three config.txt entries adjusted accordingly: https://github.com/Fourdee/DietPi/blob/ ... xt#L50-L52

These cover all types of RPi. What is not ideal with current solution, is that if you set a high split on a 1024M RPi and plug the SDcard into a 512M/256M RPi, you will have the higher value there applied as well. And since there are different allowed maximum values, it is even possible that an unsupported value is set on lower RAM RPis. Not sure how the SBC handles this case.
Would be better if we applied the chosen memory split only to the setting that matches the current RPi, e.g. only edit gpu_mem_512, if config is done from Model A+.

So yeah, if you switch your SDcard between different RPis, you might run into issues, but when keeping it in one RPi, everything should work as expected.



I opened a related GitHub issue and marked this to be solved with v6.20, since it is a potentially critical issue: https://github.com/Fourdee/DietPi/issues/2417