Page 1 of 1

Nanopi Neo2 no network after update

Posted: Tue Nov 13, 2018 10:45 pm
by 74kumi
So as the subject suggests i installed dietpi on my sd using etcher and booted. Ive tryed this 3 ways 1st static ip via dietpi.txt to get it all set up but when i set it to dhcp and reboot i get no reply on dhcp.... 2nd leaving on dhcp with the auto configuration option flagged and after its first reboot nothing 3rd manualy ssh in after it pulls dhcp the first time all i changed was adding syncthing and when it rebooted it dosn't repull dhcp am i missing something.???? short of ording a uart to try and console in is there anything i can try? is there a way to save the logs so i can see whats failing becuase logs are in the ram drive which gets dumped?? any help on this would be awsome.

Re: Nanopi Neo2 no network after update

Posted: Fri Nov 16, 2018 3:29 pm
by 74kumi
UPDATE: I bought a usb to uart, after boot an alot of garbled text i got loged in and there is no ifconfig dhclient never seems to complete, ethtool shows the interface up and connected at full gig but alot of the commands that were there before are gone.

Re: Nanopi Neo2 no network after update

Posted: Fri Nov 16, 2018 7:52 pm
by MichaIng
ifconfig is an obsolete command for the obsolete net-tools package.

Use the ip command (e.g. "ip a") instead from modern iproute2 package instead: http://xmodulo.com/linux-tcpip-networki ... oute2.html

Can you paste log/output from the dhclient? E.g. check "journalctl" or: systemctl status dhclient