MATE Desktop, KODI and Wireless Hotspot not working on v6.16

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
daozeyu
Posts: 4
Joined: Tue Oct 09, 2018 5:22 am

MATE Desktop, KODI and Wireless Hotspot not working on v6.16

Post by daozeyu »

Hi all and admins, great fan of Dietpi here and kudos to Devs on the wonderful development.

I met up with some issues on dietpi v6.16 and I am at wits end on solving it. Searched through this forum but still cannot find a solution. Hope someone here able to help me through. I am using an Odroid XU4 with fresh image installed after I gotten the bug on v6.15.
I have post a dietpi-bugreport, ref ID:95f9ad89-a855-4288-8f66-0da02081dfeb

Problem 1. I am unable to setup Mate Desktop. Using Dietpi-Software to install MATE, and setting to auto login, I keep getting an error as depicted in the picture attachment. I have retrieved the log file

Code: Select all

[  2222.291] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[  2222.291] X Protocol Version 11, Revision 0
[  2222.291] Build Operating System: Linux 4.9.0-4-armmp-lpae armv7l Debian
[  2222.291] Current Operating System: Linux DietPi 4.14.66+ #1 SMP PREEMPT Thu Aug 23 05:59:33 UTC 2018 armv7l
[  2222.291] Kernel command line: console=tty1 console=ttySAC2,115200n8 root=UUID=3032ee2a-4efc-40b6-9c1f-2839a840144d rootwait ro fsck.repair=yes net.ifnames=0 drm_kms_helper.edid_firmware=edid/1920x1080.bin smsc95xx.macaddr=00:1e:06:61:7a:72 governor=performance hdmi_tx_amp_lvl=31 hdmi_tx_lvl_ch0=3 hdmi_tx_lvl_ch1=3 hdmi_tx_lvl_ch2=3 hdmi_tx_emp_lvl=6 hdmi_clk_amp_lvl=31 hdmi_tx_res=0 HPD=true vout=hdmi  s5p_mfc.mem=16M
[  2222.292] Build Date: 16 October 2017  09:48:39AM
[  2222.292] xorg-server 2:1.19.2-1+deb9u2 (https://www.debian.org/support) 
[  2222.292] Current version of pixman: 0.34.0
[  2222.292] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  2222.292] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2222.292] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 10 04:36:13 2018
[  2222.300] (==) Using config file: "/etc/X11/xorg.conf"
[  2222.300] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2222.300] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2222.302] (==) ServerLayout "ServerLayout0"
[  2222.302] (**) |-->Screen "Default Screen" (0)
[  2222.302] (**) |   |-->Monitor "<default monitor>"
[  2222.303] (**) |   |-->Device "Mali-Fbdev"
[  2222.303] (==) No monitor specified for screen "Default Screen".
	Using a default monitor configuration.
[  2222.303] (**) Option "BlankTime" "0"
[  2222.303] (**) Option "StandbyTime" "0"
[  2222.303] (**) Option "SuspendTime" "0"
[  2222.303] (**) Option "OffTime" "0"
[  2222.303] (==) Automatically adding devices
[  2222.303] (==) Automatically enabling devices
[  2222.303] (==) Automatically adding GPU devices
[  2222.303] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2222.310] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2222.310] 	Entry deleted from font path.
[  2222.310] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  2222.310] 	Entry deleted from font path.
[  2222.310] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  2222.310] 	Entry deleted from font path.
[  2222.310] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[  2222.310] 	Entry deleted from font path.
[  2222.310] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  2222.310] 	Entry deleted from font path.
[  2222.310] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  2222.310] 	Entry deleted from font path.
[  2222.310] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	built-ins
[  2222.311] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2222.311] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2222.311] (II) Loader magic: 0x5caf60
[  2222.311] (II) Module ABI versions:
[  2222.311] 	X.Org ANSI C Emulation: 0.4
[  2222.311] 	X.Org Video Driver: 23.0
[  2222.311] 	X.Org XInput driver : 24.1
[  2222.311] 	X.Org Server Extension : 10.0
[  2222.312] (++) using VT number 1

[  2222.315] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_32
[  2222.316] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2222.316] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[  2222.317] (II) no primary bus or device found
[  2222.317] 	falling back to /sys/devices/platform/exynos-drm/drm/card0
[  2222.317] (II) LoadModule: "glx"
[  2222.320] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2222.343] (II) Module glx: vendor="X.Org Foundation"
[  2222.343] 	compiled for 1.19.2, module version = 1.0.0
[  2222.343] 	ABI class: X.Org Server Extension, version 10.0
[  2222.343] (II) LoadModule: "armsoc"
[  2222.343] (II) Loading /usr/lib/xorg/modules/drivers/armsoc_drv.so
[  2222.346] (II) Module armsoc: vendor="X.Org Foundation"
[  2222.346] 	compiled for 1.19.2, module version = 1.4.1
[  2222.346] 	Module class: X.Org Video Driver
[  2222.346] 	ABI class: X.Org Video Driver, version 23.0
[  2222.346] (II) ARMSOC: Driver for ARM Mali compatible chipsets
[  2222.346] (WW) Falling back to old probe method for armsoc
[  2222.346] (II) No BusID or DriverName specified - opening /dev/dri/card0
[  2222.346] (EE) ERROR: Cannot set the DRM interface version.
[  2222.346] (EE) ERROR: Cannot open a connection with the DRM - Permission denied
[  2222.346] (EE) No devices detected.
[  2222.346] (EE) 
Fatal server error:
[  2222.346] (EE) no screens found(EE) 
[  2222.346] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  2222.346] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2222.346] (EE) 
[  2222.361] (EE) Server terminated with error (1). Closing log file.
Problem 2. Having issue 1, I am also not able to run KODI. it gives a crash log.

Code: Select all

############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Mon  8 Oct 08:38:59 BST 2018
 Kodi Options: 
 Arch: armv7l
 Kernel: Linux 4.14.66+ #1 SMP PREEMPT Thu Aug 23 05:59:33 UTC 2018
 Release: Debian GNU/Linux 9 (stretch)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

08:38:58.224 T:2976653312  NOTICE: special://profile/ is mapped to: special://masterprofile/
08:38:58.224 T:2976653312  NOTICE: -----------------------------------------------------------------------
08:38:58.224 T:2976653312  NOTICE: Starting Kodi (17.6 Git:094825c86d). Platform: Linux ARM (Thumb) 32-bit
08:38:58.224 T:2976653312  NOTICE: Using Release Kodi x32 build
08:38:58.224 T:2976653312  NOTICE: Kodi compiled Apr 13 2018 by GCC 7.3.0 for Linux ARM (Thumb) 32-bit version 4.14.32 (265760)
08:38:58.224 T:2976653312  NOTICE: Running on Debian GNU/Linux 9 (stretch), kernel: Linux ARM 32-bit version 4.14.66+
08:38:58.226 T:2976653312  NOTICE: FFmpeg version/source: ffmpeg-3.1-kodi
08:38:58.226 T:2976653312  NOTICE: Host CPU: ARMv7 Processor rev 3 (v7l), 8 cores available
08:38:58.226 T:2976653312  NOTICE: ARM Features: Neon enabled
08:38:58.226 T:2976653312  NOTICE: special://xbmc/ is mapped to: /usr/local/share/kodi
08:38:58.226 T:2976653312  NOTICE: special://xbmcbin/ is mapped to: /usr/local/lib/kodi
08:38:58.226 T:2976653312  NOTICE: special://xbmcbinaddons/ is mapped to: /usr/local/lib/kodi/addons
08:38:58.226 T:2976653312  NOTICE: special://masterprofile/ is mapped to: /root/.kodi/userdata
08:38:58.226 T:2976653312  NOTICE: special://envhome/ is mapped to: /root
08:38:58.226 T:2976653312  NOTICE: special://home/ is mapped to: /root/.kodi
08:38:58.226 T:2976653312  NOTICE: special://temp/ is mapped to: /root/.kodi/temp
08:38:58.227 T:2976653312  NOTICE: special://logpath/ is mapped to: /root/.kodi/temp
08:38:58.227 T:2976653312  NOTICE: The executable running is: /usr/local/lib/kodi/kodi.bin
08:38:58.227 T:2976653312  NOTICE: Local hostname: DietPi
08:38:58.227 T:2976653312  NOTICE: Log File is located: /root/.kodi/temp//kodi.log
08:38:58.227 T:2976653312  NOTICE: -----------------------------------------------------------------------
08:38:58.707 T:2976653312   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanSuspend'
08:38:58.708 T:2976653312   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanHibernate'
08:38:58.713 T:2976653312  NOTICE: load settings...
08:38:58.749 T:2976653312   ERROR: PulseAudio: Failed to connect context
08:38:58.749 T:2976653312  NOTICE: PulseAudio might not be running. Context was not created.
08:38:58.787 T:2976653312  NOTICE: Found 1 Lists of Devices
08:38:58.787 T:2976653312  NOTICE: Enumerated ALSA devices:
08:38:58.787 T:2976653312  NOTICE:     Device 1
08:38:58.787 T:2976653312  NOTICE:         m_deviceName      : @
08:38:58.787 T:2976653312  NOTICE:         m_displayName     : Default (Odroid-XU4 S/PDIF)
08:38:58.787 T:2976653312  NOTICE:         m_displayNameExtra:
08:38:58.787 T:2976653312  NOTICE:         m_deviceType      : AE_DEVTYPE_IEC958
08:38:58.787 T:2976653312  NOTICE:         m_channels        : FL,FR
08:38:58.787 T:2976653312  NOTICE:         m_sampleRates     : 32000,44100,48000
08:38:58.787 T:2976653312  NOTICE:         m_dataFormats     : AE_FMT_RAW,AE_FMT_S24NE4,AE_FMT_S16NE,AE_FMT_S16LE
08:38:58.787 T:2976653312  NOTICE:         m_streamTypes     : STREAM_TYPE_AC3,STREAM_TYPE_DTSHD_CORE,STREAM_TYPE_DTS_1024,STREAM_TYPE_DTS_2048,STREAM_TYPE_DTS_512
08:38:58.798 T:2976653312  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
08:38:58.798 T:2976653312  NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
08:38:58.798 T:2976653312  NOTICE: Default Video Player: VideoPlayer
08:38:58.798 T:2976653312  NOTICE: Default Audio Player: paplayer
08:38:58.798 T:2976653312  NOTICE: Disabled debug logging due to GUI setting. Level 0.
08:38:58.798 T:2976653312  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
08:38:58.798 T:2976653312  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
08:38:58.799 T:2976653312  NOTICE: Loaded playercorefactory configuration
08:38:58.799 T:2976653312  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
08:38:58.799 T:2976653312  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
08:38:58.828 T:2976653312  NOTICE: Running database version Addons27
08:38:58.941 T:2976653312  NOTICE: ADDONS: Using repository repository.xbmc.org
08:38:59.011 T:2976653312  NOTICE: Checking resolution 16
08:38:59.011 T:2976653312  NOTICE: CWinSystemX11GLESContext::CreateNewWindow
08:38:59.013 T:2976653312  NOTICE: CWinSystemX11GLESContext::GetVisual() m_pGLContext:(nil) GetVisual
08:38:59.013 T:2976653312  NOTICE: Create new CGLContextEGL at CWinSystemX11GLESContext::CreateNewWindow, m_dpy=0x24aa910
08:38:59.029 T:2976653312   ERROR: failed to initialize egl display
08:38:59.029 T:2976653312   ERROR: Failed to find matching visual


############### END LOG FILE ################

############ END Kodi CRASH LOG #############

Problem 3. Lastly, i have setup my Dietpi as a wireless hotspot but I am unable to scan the SSID for it. My wireless dongle is blinking but no SSID is broadcasted.


I am not an IT expert here, reading the crash seems to me problem 1 and 2 is related to the video card driver. Problem 3 is something I am not very sure of..
daozeyu
Posts: 4
Joined: Tue Oct 09, 2018 5:22 am

Re: MATE Desktop, KODI and Wireless Hotspot not working on v6.16

Post by daozeyu »

Attached the Mate Desktop error log
Attachments
Error 1.jpeg
RSWeaverCo
Posts: 1
Joined: Wed Oct 10, 2018 7:22 pm

Re: MATE Desktop, KODI and Wireless Hotspot not working on v6.16

Post by RSWeaverCo »

I have the same "armsoc" module not found" problem on a Pine Rockpro64 (RK3399 CPU)
dietpi-update shows i'm at 6.16 current & server.
User avatar
MichaIng
Site Admin
Posts: 2334
Joined: Sat Nov 18, 2017 6:21 pm

Re: MATE Desktop, KODI and Wireless Hotspot not working on v6.16

Post by MichaIng »

Hmm just tested a fresh MATE install on my Stretch VM and works well there.
Screen log looks the same, besides the Xorg error messages ;).

Code: Select all

[  2222.346] (WW) Falling back to old probe method for armsoc
[  2222.346] (II) No BusID or DriverName specified - opening /dev/dri/card0
[  2222.346] (EE) ERROR: Cannot set the DRM interface version.
[  2222.346] (EE) ERROR: Cannot open a connection with the DRM - Permission denied
[  2222.346] (EE) No devices detected.
[  2222.346] (EE) Fatal server error:
[  2222.346] (EE) no screens found(EE)
[  2222.346] (EE) Please consult the The X.Org Foundation support at http://wiki.x.org

Code: Select all

08:38:58.707 T:2976653312   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanSuspend'
08:38:58.708 T:2976653312   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanHibernate'
Definitely an issue on Xorg basis, jep perhaps video driver, thus makes sense that Kodi and desktop both don't work. I will open an issue on GitHub for investigation.

Issue opened: https://github.com/Fourdee/DietPi/issues/2130
@daozeyu feel free to add further information to the issue.
daozeyu
Posts: 4
Joined: Tue Oct 09, 2018 5:22 am

Re: MATE Desktop, KODI and Wireless Hotspot not working on v6.16

Post by daozeyu »

MichaIng wrote: Thu Oct 11, 2018 3:26 am Hmm just tested a fresh MATE install on my Stretch VM and works well there.
Screen log looks the same, besides the Xorg error messages ;).

Code: Select all

[  2222.346] (WW) Falling back to old probe method for armsoc
[  2222.346] (II) No BusID or DriverName specified - opening /dev/dri/card0
[  2222.346] (EE) ERROR: Cannot set the DRM interface version.
[  2222.346] (EE) ERROR: Cannot open a connection with the DRM - Permission denied
[  2222.346] (EE) No devices detected.
[  2222.346] (EE) Fatal server error:
[  2222.346] (EE) no screens found(EE)
[  2222.346] (EE) Please consult the The X.Org Foundation support at http://wiki.x.org

Code: Select all

08:38:58.707 T:2976653312   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanSuspend'
08:38:58.708 T:2976653312   ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property 'CanHibernate'
Definitely an issue on Xorg basis, jep perhaps video driver, thus makes sense that Kodi and desktop both don't work. I will open an issue on GitHub for investigation.

Issue opened: https://github.com/Fourdee/DietPi/issues/2130
@daozeyu feel free to add further information to the issue.
thanks @MichaIng for helping to open the problem ticket.

I found a workaround online guiding me to start MATE desktop.
I deleted xorg.conf and MATE desktop miraculously start. Next, I installed KODI from dietpi-software and the same issue arises.
I get the xorg unable to start error.

doing the same workaround on the generated new xorg.conf, MATE desktop once again starts but KODI in MATE does not start.
it seems either the XORG.conf is having some problem or that Xserver is having the problem.

Hope this additional information helps.
Post Reply