Page 2 of 2

Re: Rpi unknown

Posted: Thu Jul 07, 2016 9:21 pm
by Fourdee
RasPiHacker wrote:Hi Fourdee!

Have been hospitalized for two weeks, just seen Your post today.

I have tried all the other suggestions in the forums regarding update problems on the V.115, but none has worked.

dietpi-update with no or any option (1,2,3) returns the same error:

Code: Select all

Checking for DietPi updates, Please wait...
curl: (3) Illegal characters found in URL
cat /DietPi/dietpi.txt | grep 'git'
returns this:

Code: Select all

root@DietPiZero:~# cat /DietPi/dietpi.txt | grep 'git'
Hi RasPiHacker,

No worries, hopefully your onto a good recovery?

The inability to update is most likely the line endings in dietpi.txt being dos, instead of unix. This can occur when a user edits the file on a Windows PC with notepad/wordpad.

To resolve this, please run the folllowing commands, as per this post: ... -228723958

Code: Select all

sed -i $'s/\r$//' /DietPi/dietpi.txt
Please let me know the results :)

Re: Rpi unknown

Posted: Thu Jul 07, 2016 9:38 pm
by RasPiHacker
Hi again.

I had tried everything in this thread:Raspberry Pi 3 wont update, but noting worked.
sed -i $'s/\r$//' /DietPi/dietpi.txt
Running the above fixed it, thank You Fourdee!

Strange since I have not used anything but Putty to connect via serial cable to the Zero, and nano, once logged in, to edit files on the Zero.


Code: Select all

 DietPi     | 21:29 | Thu 07/07/16
 V122       | RPi Zero (armv6l)
 IP Address |
It works a treat now, thank You again and keep up the good work!!