Page 1 of 1

DietPi 6 SSH login problems

Posted: Wed Jan 31, 2018 3:49 pm
by BobC
Hi have login details changed?
On my Mac Terminal i have tried to SSH into both RPi and Allo versions of V6 without success. I have worked on previous iterations without problem.
On entering 'dietpi' as password I get...


Root@(ip no)'s password:
Permission denied, please try again.

Any suggestions (i have ensured that caps lock is off)?

Thanks in advance

Re: DietPi 6 SSH login problems

Posted: Sat Feb 03, 2018 8:14 pm
by MichaIng
Hmm and you did not change the global password within dietpi.txt? Can you log in directly on RPi console with default credentials?

Re: DietPi 6 SSH login problems

Posted: Sun Feb 04, 2018 6:43 pm
by TheMongoose
I'm having a similar issue on my Mac.

I can connect to the console as root. In the Terminal, I can ssh in as dietpi, but that user doesn't have root privileges. I can't su or directly ssh in as root, I just get the same "Permission denied" as BobC.

SSH worked fine on the old version. I've tried both Dropbear and OpenSSH, both give the same results.