Page 1 of 1

[RESOLVED] -Dietpi v 156 will not load I-Sabre K2M driver??

Posted: Thu Oct 19, 2017 6:26 pm
by Deaks
I tried a fresh image again this morning, this time the system updated to 157, and I'm pleased to say that all is good again :-)

Now I can get back to adding more storage to my Roon Server :-)

Deaks
------------------------------------

Please help!!

For a couple of months I have been running DietPi 150 and RoonBridge + Roon 262 without any issues (apart from clicking on DSD upsampling which is a known issue).

Stupidly I thought I would SSH into the Pi and look at changing to a static IP instead of DHCP......
The dietPi started to update to 156 and also updated the kernel to 4.9, since then I cant the Audiophonics card to load properly :-(

I have reloaded a clean OS on MicroSD, hoping I could see if the original 150 build was OK still, but it keeps updating its self to 156.
I managed to roll back the kernel to 4 4 5 but still problems.

David from Audiphonics has been helpful but his advice to reboot and reapply the settings didn't help.

I found that the generic rpi_dac driver would install and then I could get sound out of the Roon software, but the max sample rate is 192 and no DSD option unlike the I sabre driver.

is it possible to do a fresh dietpi install without it automatically updating to 156?

is anyone else running the latest build of dietpi with the Audiophonics I-Sabre ES9028Q2M DAC without issue?

I've spent hours so far, when I have I-Sabre driver loaded, # speaker-test -c2 I get an error:-

Playback open error: -2, no such file or directory

When I load the rpi_dac driver (which gives sound output) I get this message:-

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels

then it alternates playing out pink noise on the left then right output until I ctrl +c to caancel.

Another thing I notice, is when I have loaded the I-Sabre driver and reboot, on the loading screen, I see a message:-
FAIL: unable to store soundcard state

Somethings broken but I cant figure it out, any help would be gratefully received.

Deaks

Re: Dietpi v 156 will not load I-Sabre K2M driver??

Posted: Thu Oct 19, 2017 11:18 pm
by Fourdee
Hi Deaks,

I tested the I-Sabre K2M with DietPi v156 + RPi3, and its working fine our end.

Can you please confirm you have re-selected the soundcard in dietpi-config ?
Untitled (1).png
As per the image, this is required to install the new driver to match the updated kernel version.

If problems persist, after this, please let us know the RPi model used (eg: RPi3), we'll investigate.

Re: Dietpi v 156 will not load I-Sabre K2M driver??

Posted: Fri Oct 20, 2017 12:52 am
by Deaks
Thanks for the quick response.

I dont get that message come up when I select the I-sabre device??
The card I am using is the Audiophonics I-Sabre DAC ES9028Q2M + Kali reclocker.
I still have the issue even without the kali installed??
Previously I had been using the I-sabre-K2m driver without any problem.

I'm installing dietpi using the DietPi_v150_RPi-armv6-(Jessie).img, which then updates to 156.

Is there another image I can use to see if that resolves it?

The SBC is a Raspberry Pi 3 model B.

I have reimaged two different microsd cards and still have issues.
Any idea why I dont get to see the dialogue box you refer to?

Thanks in advance


Deaks