Page 1 of 1

[Solved] Owncloud installation trouble

Posted: Tue Nov 24, 2015 1:51 pm
by skyfly555
Hello, I'm amazed with DietPi, it works so good!
I've installed a lot of nice software, just with the "DietPi-Software", so easy and quick, I love it!

But I have had a trouble with OwnCloud installation, I think because of my ignorance, maybe someone can help me :D

I have connected from "the outside", with my Mac using NOIP domain :D and not from local network (I was not at home at that very moment).
I've created root user and a password, and then I clicked something wrong (maybe "Login"), not the "finishing the installation" button (I don't know if this is the english name of the button, my installation is spanish), so I went into there and couldn't configure what needed, as you can see in the Fourdee guide, http://dietpi.com/phpbb/viewtopic.php?f=8&t=5#p47
that says...

The first time you connect:
- Create your Admin account, type in a username and password (I just could do THIS)
FROM HERE, NOTHING DONE ,YET.
- Click Storage & Database or Advanced to expand the submenu.
- Database type = MySQL
- DataFolder = /var/lib/owncloud/data
- Database User = root
- Database Password = raspberry
- Database Name = owncloud
- Click Finish setup to complete the Owncloud setup

Do you know how I can create the database and so on? I don't know if the wizard can be opened from somewhere, or how to do it manually,

Thank you very much,

Re: Owncloud installation trouble

Posted: Tue Nov 24, 2015 2:26 pm
by Fourdee
Hi SkyFly,

The simplest way to return to the initial setup would be to reinstall owncloud. Run the following:

Code: Select all

dietpi-uninstall OWNCLOUD
rm -R /var/www/owncloud
Then run dietpi-software and reselect Owncloud for installation:

Code: Select all

dietpi-software
There is proabably another method to resetting Owncloud back to its initital state, however, I've not tested it.: http://forums.openmediavault.org/index. ... #post25250

Re: Owncloud installation trouble

Posted: Tue Nov 24, 2015 11:13 pm
by skyfly555
Thank you very much, Fourdee.

I've done what you said, unistalling and re-installing it, it worked perfectly!

Thanks again, I love DietPI :D

Re: Owncloud installation trouble

Posted: Wed Nov 25, 2015 9:02 pm
by Fourdee
skyfly555 wrote:Thank you very much, Fourdee.

I've done what you said, unistalling and re-installing it, it worked perfectly!

Thanks again, I love DietPI :D
No worries. Great to hear good feedback :)