Page 1 of 1

NanoPi NEO first wireless dongle is wlan3

Posted: Thu Dec 15, 2016 7:31 pm
by Gord_W
I attached a wifi dongle to a NanoPi NEO and was expecting the device name would be wlan0. Instead it came up wlan3. Is that by design or is it a problem? The issue is trying to wirelessly set the NEO up without ethernet, one doesn't know what wlan device name should be used.
Gordon Williams

root@NanoPi:~# ifconfig
eth0 Link encap:Ethernet HWaddr 0e:13:de:11:a2:c1
inet addr:192.168.1.104 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::c13:deff:fe11:a2c1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4837 errors:0 dropped:0 overruns:0 frame:0
TX packets:1371 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:373591 (364.8 KiB) TX bytes:236710 (231.1 KiB)
Interrupt:114

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:400 (400.0 B) TX bytes:400 (400.0 B)

wlan3 Link encap:Ethernet HWaddr 00:e0:4c:81:92:c2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Re: NanoPi NEO first wireless dongle is wlan3

Posted: Thu Dec 15, 2016 7:40 pm
by Gord_W
One more bit of info.

When I rebooted the wifi came up as wlan4 now. So it is a moving target.

root@NanoPi:~# ifconfig
eth0 Link encap:Ethernet HWaddr 0e:13:de:11:a2:c1
inet addr:192.168.1.104 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::c13:deff:fe11:a2c1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:869 errors:0 dropped:0 overruns:0 frame:0
TX packets:1050 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:64043 (62.5 KiB) TX bytes:179666 (175.4 KiB)
Interrupt:114

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:400 (400.0 B) TX bytes:400 (400.0 B)

wlan4 Link encap:Ethernet HWaddr 00:e0:4c:81:92:e4
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@NanoPi:~# iwconfig
lo no wireless extensions.

tunl0 no wireless extensions.

eth0 no wireless extensions.

wlan4 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:off