wpa_supplicant daemon failed to start

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
ezemsm@gmai.com
Posts: 2
Joined: Wed Nov 08, 2017 2:05 pm

wpa_supplicant daemon failed to start

Post by ezemsm@gmai.com » Wed Nov 08, 2017 2:16 pm

Hi forum,
Love Dietpi interface.
Using dietpi on rock64 board via eth0.
Enabled wifi via dietpi-config.
Which then downloaded netplug in background.

Code: Select all

root@DietPi:~# ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlan0
 

Changed :/etc/network/interfaces/interfaces to:

Code: Select all

# Wifi
allow-hotplug wlan0
iface wlan0 inet dhcp
address 192.168.0.150
netmask 255.255.255.0
gateway 192.168.0.1
wireless-essid U-8-Dingle******s
wireless-key my-password
wireless-mode Managed
wireless-power off
wpa-ssid U-8-Dingle******s
wpa-psk my-password
#dns-nameservers 8.8.8.8 8.8.4.4
Thanks in advance
-sam

User avatar
WarHawk
Posts: 254
Joined: Thu Jul 20, 2017 7:55 am

Re: wpa_supplicant daemon failed to start

Post by WarHawk » Thu Nov 09, 2017 5:45 am

Try putting the ssid in double quotes " in the /etc/network/interfaces/ file

wireless-essid U-8-Dingle******s
and
wpa-ssid U-8-Dingle******s

to wireless-essid"U-8-Dingle******s" no spaces between ssid and the double quote "

Also I believe there should be an = sign between the descriptor and the value, with no spaces
#=Wifi
allow-hotplug=wlan0
iface=wlan0=inet=dhcp
address=192.168.0.150
netmask=255.255.255.0
gateway=192.168.0.1
wireless-essid="U-8-Dingle******s"
wireless-key="my-password"
wireless-mode=Managed
wireless-power=off
wpa-ssid="U-8-Dingle******s"
wpa-psk="my-password"
#dns-nameservers=8.8.8.8=8.8.4.4

bobstro
Posts: 1
Joined: Wed May 17, 2017 7:27 pm

Re: wpa_supplicant daemon failed to start

Post by bobstro » Fri Nov 10, 2017 1:26 am

I had the same problem on a tinkerboard install. I changed my /etc/wpa_supplicant/wpa_supplicant to:

Code: Select all

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

ezemsm@gmai.com
Posts: 2
Joined: Wed Nov 08, 2017 2:05 pm

Re: wpa_supplicant daemon failed to start

Post by ezemsm@gmai.com » Sun Nov 12, 2017 11:08 am

Apologizes first forum joined that had the email reply notifications off.

Code: Select all

# Wifi
allow-hotplug wlan0
iface wlan0 inet dhcp
address 192.168.0.150
netmask 255.255.255.0
gateway 192.168.0.1
wireless-essid "U-8-DingleB*****s"
wireless-key "password"
wireless-mode Managed
wireless-power off
wpa-ssid "U-8-DingleB*****s"
wpa-psk "password"
#dns-nameservers 8.8.8.8 8.8.4.4
Did ifup wlan0 got this:

Code: Select all

root@DietPi:~# ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlan0
then attempted wpa_supplicant.config manipulation via second post and realized currently there is no wpa_supplicant.config file in the directory /etc/wpa_supplicant. Is there one required to be there?

Code: Select all

root@DietPi:/etc/wpa_supplicant# dir
action_wpa.sh  functions.sh  ifupdown.sh

Also how do I view the system log? I have spent hours googling, I get the information about how ram-log is setup to delete every hour by default ok, but how do i view it?(htop?) Also lsmod only has 2 modules used neither of which are wifi related. In the past expected a driver for the wifi device.I noticed that at the top of network interfaces file there are comments that highly recommend using dietpi interface to edit network settings. Also the coding for the files in wpa_supplicant are very well written and aren't simply one liners. Optimization is key but looking through some else's code trying to understand the layout becomes cumbersome due to complexity.

Thank you for your time,
Sam

User avatar
WarHawk
Posts: 254
Joined: Thu Jul 20, 2017 7:55 am

Re: wpa_supplicant daemon failed to start

Post by WarHawk » Tue Nov 14, 2017 7:53 am

System log is still in /var/log but in compressed format in RAM (I believe)

cat /var/log/system

Going to need someone else to join the fray....

Post Reply