can't install on qnap debian VM Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

can't install on qnap debian VM

Post by manilx »

I tried to install dietpi on a freshly created debian10 VM running on Virtualization Station of a QNAP.
When I try to run the install script (https://dietpi.com/docs/dietpi_sbc/#mak ... stribution) selecting master
chmod +x PREP_SYSTEM_FOR_DIETPI.sh
./PREP_SYSTEM_FOR_DIETPI.sh
I get: [FAILED] DietPi-PREP | Unknown or unsupported CPU architecture: "i686". Aborting...

I have selected "Intel Core i7 (Westmere)" as the CPU version in the VM.

Any chance to get this installing?
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: can't install on qnap debian VM

Post by manilx »

Succeded in getting the script to run by changing the line and replacing x86 with i686.

But after entering name etc I got this:
Image
Attachments
ScreenShot 2021-04-21 at 13.40.20.png
User avatar
Joulinar
Posts: 4453
Joined: Sat Nov 16, 2019 12:49 am

Re: can't install on qnap debian VM

Post by Joulinar »

Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: can't install on qnap debian VM

Post by manilx »

OK....
User avatar
Joulinar
Posts: 4453
Joined: Sat Nov 16, 2019 12:49 am

Re: can't install on qnap debian VM

Post by Joulinar »

if possible you would need to use x86_64 as architecture.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: can't install on qnap debian VM

Post by manilx »

Joulinar wrote: Wed Apr 21, 2021 3:06 pm if possible you would need to use x86_64 as architecture.
It's not worth the while.... Was testing. I'll remain on the 2 pie4's and Zotac I have running.

Thx!
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: can't install on qnap debian VM

Post by manilx »

I wrongly donwloaded the 32bit debian CD...

Tried again with 64bit one:

Worked without a hitch!!!
User avatar
Joulinar
Posts: 4453
Joined: Sat Nov 16, 2019 12:49 am

Re: can't install on qnap debian VM

Post by Joulinar »

Yep it would need to be 64bit image. Personally I'm running a couple of demo VM's on my Synology NAS using the VirtualBox image.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
manilx
Posts: 77
Joined: Mon Dec 07, 2020 11:02 am

Re: can't install on qnap debian VM

Post by manilx »

I’ll try that image also
EDIT: installed on Qnap Vrirtual Station but didn't boot from the disk.....
User avatar
Joulinar
Posts: 4453
Joined: Sat Nov 16, 2019 12:49 am

Re: can't install on qnap debian VM

Post by Joulinar »

on Synology I need to import the OVA file to be able to run a VM from it. Simply creating a VM is not working as well. Not sure how this is on QNAP.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply