Can not update after v6.17.12

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
RedRaymann
Posts: 10
Joined: Mon Jun 05, 2017 3:17 pm

Can not update after v6.17.12

Post by RedRaymann » Fri Feb 15, 2019 5:24 pm

Finally i've some time to report my problem.

I can't update my DietPi.
This RaspberryPi worked for a long time flawless. But after i've tried to update v6.17.12 it gave an error. i hope that there is all the information, otherwise i will update it.

Hardware;
Raspberry Pi 3b
MicroSD Class 10 8GB (brand; www.sossolutions.nl)

Software;
DietPi 6.17
Domoticz Stable
V4.9700
libusb-0.1-4
ProFTP (By DietPi)
Monit
SNMPd
SNMP
netcat
Xiaomi Vacuum Robot (MIIO Server)
python3
python3-dev
python3-pip
setuptools (pip)
virtualenv (pip)
msgpack (pip)
python-miio (pip)
libffi-dev
libssl-dev
Mosquitto MQTT

Report in SSH - with answers
#### Details:
- Date | Fri 15 Feb 17:14:59 CET 2019
- Bug report | N/A
- DietPi version | v6.17.12 (Fourdee/master)
- Img creator | DietPi Core Team
- Pre-image | Raspbian Lite
- SBC device | RPi 3 Model B (armv7l) (index=3)
- Kernel version | #1159 SMP Sun Nov 4 17:50:20 GMT 2018
- Distro | stretch (index=4)
- Command | G_AGUP
- Exit code | 139
- Software title | DietPi-Update

#### Steps to reproduce:
<!-- Explain how to reproduce the issue -->
After log-in as ROOT
type "dietpi-update", enter
Update screen appears with message update available
Select "Update", enter
Do you want to continue and update DietPi to v6.21.1? -> select "Ok"

#### Expected behaviour:
<!-- What SHOULD be happening? -->
Dietpi should update

#### Actual behaviour:
Screen appears
DietPi Error Handler
Retry of DietPi Config

-> Retry = Same problem
-> DietPi-Config = Opens Config screen

#### Extra details:
<!-- Please post any extra details that might help solve the issue -->
2nd Raspberry Pi 3B with Kodi, PiVPN, PiHole updates with no problem (Cable)
Raspberry Pi 0W with Domoticz, Grafana and Dutch P1 cable updates with no problem (WiFi)

Already format SD with windows PC, wrote old backup to SD, tried and faled (WiFi and Cable)
Already tried other SD (16GB) true WiFi and Cable
Already tried other (3th) Rastberry Pi 3B (16Gb Micro SD card with old back-up, WiFi and Cable)
Already with and without PiHole enabled
There is internet connection (Ping google.com)


#### Additional logs:
Bug report sent, reference code: 164fcca4-2d81-4693-96b6-59e97e3e1a13

Log file contents:
Where can i find the logfile?

This is what i see after entering "dietpi-update"

Code: Select all

[email protected]:~# dietpi-update
[  OK  ] DietPi-Update | Root access verified.
[  OK  ] DietPi-Update | RootFS R/W access verified.


 DietPi-Update
─────────────────────────────────────────────────────
 Mode: Checking for DietPi updates

[ INFO ] DietPi-Update | Checking mirror: https://raw.githubusercontent.com/Fourdee/DietPi/master/dietpi/server_version-6
[  OK  ] DietPi-Update | Using update server: https://raw.githubusercontent.com/Fourdee/DietPi/master/dietpi/server_version-6

[  OK  ] DietPi-Update | Update available
[ INFO ] DietPi-Update | Current version : v6.17.12
[ INFO ] DietPi-Update | Latest version  : v6.21.1
[  OK  ] DietPi-Update | DietPi-Userdata validation: /mnt/dietpi_userdata
[  OK  ] DietPi-Update | Free space check: path=/ | available=5580 MB | required=100 MB
[ SUB1 ] DietPi-Services > stop
[  OK  ] DietPi-Services | stop : cron
[  OK  ] DietPi-Services | stop : mosquitto
[  OK  ] DietPi-Services | stop : proftpd
[  OK  ] DietPi-Update | wget https://raw.githubusercontent.com/Fourdee/DietPi/master/dietpi/pre-patch_file -O pre-patch_file

 DietPi-Pre-patch
─────────────────────────────────────────────────────
 Mode: Applying critical pre-patches

[  OK  ] Successfully applied critical pre-patches

[  OK  ] DietPi-Update | APT update, please wait...

[FAILED] DietPi-Update | G_AGUP
[  OK  ] DietPi-Update | APT update, please wait...

[FAILED] DietPi-Update | G_AGUP

User avatar
MichaIng
Legend
Posts: 1014
Joined: Sat Nov 18, 2017 5:21 pm

Re: Can not update after v6.17.12

Post by MichaIng » Thu Feb 21, 2019 3:38 pm

Please manually run "apt update" and report back the output.

RedRaymann
Posts: 10
Joined: Mon Jun 05, 2017 3:17 pm

Re: Can not update after v6.17.12

Post by RedRaymann » Fri Mar 01, 2019 4:29 pm

Hmmm, I’m afraid that I’ve found the problem.

After "apt-get update" or "apt update" the following is displayed;
"Segmentation fault"

So... I can't find a way to repair this (search on duckduckgo/google)
I think will buy a new MicroSD card and start all over. The problem is probably also in the back-up. Because I’ve used an old backup after I’ve noticed this problem.

If there is another solution, I hope you all will help me.

davidhbolton
Posts: 1
Joined: Sat Mar 02, 2019 7:19 pm

Re: Can not update after v6.17.12

Post by davidhbolton » Sat Mar 02, 2019 7:26 pm

Just to add my problems with 6.21.1 on a Raspberry Pi 3 B+. I installed a 6.20.6 last month and it worked fine. Today I logged in for the first time in a month and it told me there was an update.

It ran for quite a while downloading etc rebooted and then it ran 15 (I think) finalization scripts and each had the same syntax error. It was something like 'error after the for'. And the version wasn't updated, so after it rebooted, it offered me an upgrade again.

I tried another path- downloading the latest stretch and burning on Windows. It also is 6.20.6 and after installing does an update and will keep rebooting and doing the same update steps, time after time unless you ctrl-c out. So I think this release on Raspis is a little bit broken. It only seems to be the last bit with the syntax errors.

User avatar
MichaIng
Legend
Posts: 1014
Joined: Sat Nov 18, 2017 5:21 pm

Re: Can not update after v6.17.12

Post by MichaIng » Sun Mar 10, 2019 5:27 pm

@davidhbolton @RedRaymann
Please try the newly uploaded RPi image, which resolves some boot issues on RPi: https://dietpi.com/downloads/images/Die ... Stretch.7z

RedRaymann
Posts: 10
Joined: Mon Jun 05, 2017 3:17 pm

Re: Can not update after v6.17.12

Post by RedRaymann » Thu Mar 14, 2019 7:37 pm

Thanks, the new SDcards are ordered. I will start all over with the new image.

bradleyq
Posts: 1
Joined: Fri Mar 15, 2019 8:57 am

Re: Can not update after v6.17.12

Post by bradleyq » Fri Mar 15, 2019 9:00 am

Did it help resolve the boot issues on RPI?
Why is Monday so far from Friday...
192.168.0.1

Post Reply