Search found 42 matches

by ghettopi
Wed Aug 07, 2019 12:02 am
Forum: Troubleshooting
Topic: WireGuard DNS after latest upgrade
Replies: 26
Views: 3937

Re: WireGuard DNS after latest upgrade

Solved! Solution was to remove everything from AllowedIPs and change it back to 0.0.0.0/0. Now everything works. For some reason it didn't kill my local network connection and SSH this time... No idea why it did last time. Maybe fail2ban was to blame? Either way I moved to ufw which I like much more...
by ghettopi
Tue Aug 06, 2019 11:59 pm
Forum: General Discussion
Topic: Share your Pi Speedtests! [Script]
Replies: 1
Views: 318

Share your Pi Speedtests! [Script]

Hey folks. Share your Pi Speedtests! Let's see who has the Pi with the fastest internet connection ;) Remember to remove your public IP address! Run this command from a terminal :) Source here! It's 100% safe. curl -s https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py | python...
by ghettopi
Tue Aug 06, 2019 10:20 pm
Forum: Troubleshooting
Topic: WireGuard DNS after latest upgrade
Replies: 26
Views: 3937

Re: WireGuard DNS after latest upgrade

Hi I'm bumping this MichaIng because I am getting the exact same issue when trying to use Wireguard. As soon as I start the service, I start getting DNS resolving issues. Please see this thread: https://dietpi.com/phpbb/viewtopic.php?f=11&t=6191 Do I have to go through the same steps as the other us...
by ghettopi
Tue Aug 06, 2019 10:07 pm
Forum: Troubleshooting
Topic: [Solved] Running a command at boot?
Replies: 3
Views: 236

Re: [Solved] Running a command at boot?

I think I found one way I am happy with for now. FWIW I simply added a script into the dietpi postboot.d folder. And within that one-line-script I start wireguard service via systemctl start [email protected]. Works reliably for me. Sorry I didn't get to you in time, but I'm glad you sorted it out quick...
by ghettopi
Tue Aug 06, 2019 9:59 pm
Forum: General Discussion
Topic: Auto mounting of a share fails on boot?
Replies: 4
Views: 669

Re: Auto mounting of a share fails on boot?

You definitely shouldn't have to edit any other file except fstab. What type of drive is it? i.e. what is it formatted as? Are you sure that your fstab entry is correctly formatted? I recently started having issues with mounting myself actually. Funny it was fine when using exfat but as soon as I fo...
by ghettopi
Tue Aug 06, 2019 9:53 pm
Forum: Troubleshooting
Topic: Wireguard + Mullvad. How to?
Replies: 1
Views: 320

Wireguard + Mullvad. How to?

Just what it says. What's the correct setup for these two? I want to cover my Raspberry Pi 4 with my VPN from Mullvad using Wireguard. I can download the .conf files from the Wireguard site and even make the keys there. Here's an example of the conf I am using: [Interface] PrivateKey = (private) Add...
by ghettopi
Tue Aug 06, 2019 5:35 pm
Forum: General Discussion
Topic: The new Raspberry Pi 4
Replies: 87
Views: 36134

Re: The new Raspberry Pi 4

Well I got a Noctua NF-A4x10 5V Fan which runs very quickly and kinda loud (~4500 rpm). Also I am sure that the fans are spinning in the wrong direction but the device has some 'polarity protection' that is meant to prevent the fans being plugged in the wrong way. So I dunno. I did see people on You...
by ghettopi
Fri Aug 02, 2019 6:05 pm
Forum: General Discussion
Topic: The new Raspberry Pi 4
Replies: 87
Views: 36134

Re: The new Raspberry Pi 4

Here you go (I've the 2GB Version of the Rpi4: │ Benchmarks completed: │ │ - CPU Performance : Duration = 44.87 seconds (lower is faster) │ │ - CPU Temp : Idle = 71'c | Full load = 74'c │ │ - RootFS : Write = 13 MiB/s | Read = 33 MiB/s │ │ - RAM : Write = 81 MiB/s | Read = 154 MiB/s and with sdram_f...
by ghettopi
Fri Aug 02, 2019 4:29 pm
Forum: Troubleshooting
Topic: Just qBittorrent under VPN?
Replies: 1
Views: 318

Just qBittorrent under VPN?

How to do this, I'm sure I'm not the only one? I'd like it done preferably with Wireshark. I don't need/want every single connection running through Wireshark, just those from qBittorrent and I also need access to my Pi via LAN of course. When running the following .conf from my VPN provider. I inst...
by ghettopi
Wed Jul 31, 2019 11:34 pm
Forum: Troubleshooting
Topic: [Solved] Running a command at boot?
Replies: 3
Views: 236

[Solved] Running a command at boot?

Hi, I borked my installation by auto enabling Wireguard every time at boot which is not letting me SSH into the system or access any of the services running on my device. I'd like to run a simple command at boot that would disable Wireguard from running automatically. Then after rebooting the device...