Search found 7 matches

by BennyBubble
Thu Nov 01, 2018 10:09 am
Forum: General Discussion
Topic: RPi.GPIO issues after update
Replies: 8
Views: 1114

Re: RPi.GPIO issues after update

Hi, Did follow your advise and ONLY ran update & upgrade, this already coaused the same problem as before. Update results: [email protected]# apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages will be upgrad...
by BennyBubble
Tue Oct 30, 2018 3:59 pm
Forum: General Discussion
Topic: RPi.GPIO issues after update
Replies: 8
Views: 1114

Re: RPi.GPIO issues after update

Hi, Ran the 3 line script but no luck, same error message. Also had a look at the given links but they did not help either. I'm logged in as root so no need for sudo I assume? It is not a firmware change, lucky enough (learned by error) I had a backup which was 6.16, after restoring it al works fine...
by BennyBubble
Tue Oct 30, 2018 7:28 am
Forum: General Discussion
Topic: RPi.GPIO issues after update
Replies: 8
Views: 1114

RPi.GPIO issues after update

Hi, After updating yesterday my dietpi-based system from 6.16.?? to 6.17.12, I suddenly cannot run a python script. Error message: GPIO.add_event_detect(azPuls, GPIO.RISING, callback=azpuls_interrupt, bouncetime=10) RuntimeError: Failed to add edge detection initially I thought it was my code but I ...
by BennyBubble
Tue Mar 20, 2018 2:59 pm
Forum: Troubleshooting
Topic: samba and lighttpd won't start automatically (v6.4) [solved]
Replies: 6
Views: 891

Re: samba and lighttpd won't start automatically (v6.4)

Hi,
Still don't know how to setup dietpi so that all services start automatically, please help!
-ben
by BennyBubble
Sat Mar 17, 2018 4:00 pm
Forum: Troubleshooting
Topic: samba and lighttpd won't start automatically (v6.4) [solved]
Replies: 6
Views: 891

Re: samba and lighttpd won't start automatically (v6.4)

After dietpi-services start : [email protected]:~# dietpi-services start [ OK ] Root access verified. DietPi-Services ───────────────────────────────────────────────────── Mode: start [ OK ] DietPi-Services | start : cron [ OK ] DietPi-Services | start : smbd [ OK ] DietPi-Services | start : nmbd [ OK ] Die...
by BennyBubble
Sat Mar 17, 2018 3:57 pm
Forum: Troubleshooting
Topic: samba and lighttpd won't start automatically (v6.4) [solved]
Replies: 6
Views: 891

Re: samba and lighttpd won't start automatically (v6.4)

First command after boot : [email protected]:~# dietpi-services status [ OK ] Root access verified. DietPi-Services ───────────────────────────────────────────────────── Mode: status [ INFO ] DietPi-Services | cron inactive (dead) [ INFO ] DietPi-Services | smbd inactive (dead) [ INFO ] DietPi-Services | nm...
by BennyBubble
Fri Mar 16, 2018 2:10 pm
Forum: Troubleshooting
Topic: samba and lighttpd won't start automatically (v6.4) [solved]
Replies: 6
Views: 891

samba and lighttpd won't start automatically (v6.4) [solved]

Hi, Recently I've installed dietpi on my rpi 2 b+, all works well, very happy :D :D ! However after installing samba server and lighttpd/mariadb (using dietpi-software), I noticed they won't start automatically. After boot I first have to ssh into the rpi and start both services, after which both ru...