Zennity issues ?

I like to use fluxion ( wireless pen testing app) and it requires that i install zenity. When i try to install zenity (apt-get install zenity) it gives me the following error… what should i do ?

root@DietPi:~/fluxion# sudo apt-get install Zenity
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zenity : Depends: libwebkit2gtk-4.0-37 (>= 2.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


It looks like libwebkit2gtk package is not available in any apt repos on your system. I’ll try to replicate, can you please tell me what device you are using (eg: RPi 3)?

Yes i am using the rpi3 model B

Can you please send a bug report.
This will contain information on your system (eg: what software is installed, desktop etc). Will help me with debugging.


Follow the onscreen instructions, ignore the text document (no need to fill it out), then reply with your reference code.

In the mean time, you may want to try the following to clear apt cache and run updates:

apt-get clean
apt-get update
apt-get install -f
apt-get autoremove --purge -y
apt-get upgrade -y

Then try:

apt-get install Zenity

still doesn’t work, but i was able to get a bug report,

this one before i attempted sudo apt-get install Zenity.
Reference CODE: 081264fc-203b-4d06-b3fc-9654ea3f695e-0

and this is the one after i entered the command sudo apt-get install Zenity
Reference CODE: 081264fc-203b-4d06-b3fc-9654ea3f695e-1

Try disabling kali repo:
Copy and paste all of this into a terminal

cat << _EOF_ > /etc/apt/sources.list
# RPi repo.
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

# Kali linux repositories | Added by Katoolin
#deb http://http.kali.org/kali kali-rolling main contrib non-free

Refresh apt-cache, Install zenity

apt-get clean
apt-get update
apt-get install -f
apt-get autoremove --purge -y
apt-get upgrade -y
apt-get install zenity

If the same error occurs, you have packages installed (most likely from kali) that are preventing Zenity shared libraries from being installed.

Try removing libwebkit2gtk and see if it lists any more programs:

apt-get purge libwebkit2gtk*

Failing that, try installing libwebkit2gtk-4.0-37 and see if it reports any dependency issues:

apt-get install libwebkit2gtk-4.0-37