XU4 v151 backup/restore problem

Hi Fourdee,

Again restoring from backup the contents of /var/www/html were not copied back - same three times today. Easy to do manually and the restore otherwise worked fine.

At the end of the restore there was a message about not enough room but on reboot the log file is empty. Any idea why this is?

John

Hi John,

Most likely insufficient space on RootFS? Check available space with

df -h

Logs are cleared by DietPi-RAMlog during reboots. Best to check them prior to the reboot :slight_smile:

The same happened on 32 GB eMMC, 32 GB SD and 16 SD. The system uses around 8 GB so shouldn’t be lack of space?

Incidentally two failed eMMC recently one a bit less than a year old and the other three months old. They wouldn’t replace the first and I doubt they’ll replace the second either.

John

Hi John,

Interesting, I’ve got 3 EMMC’s, all over a year old. One of them is used daily in DietPi testing (lots of IO/backups/restores), still going strong.

Have you tried full formatting the EMMC to see if that revives it, and use a new EMMC > SD adapter?
https://github.com/Fourdee/DietPi/issues/769#issuecomment-283030267

Hmm looks like a 2 week warranty for EMMC’s:
https://forum.odroid.com/viewtopic.php?f=53&t=661

The system uses around 8 GB so shouldn’t be lack of space?

Could be rootFS is mounted as read only, especially if the EMMC is failing. Ideally, if you run the update again, try to copy/paste the error you see on screen.

Hi Fourdee,

This is the second eMMC to fail - last time tried everything the Odroid forum suggested. Little doubt it was stuffed as it got too hot to touch when plugged in to a desktop USB port. I have two eMMC adaptors and two usb adaptors that work with the eMMC so not looking good this second time. I’ll try the Android SD method again when I get home tonight:

http://odroid.com/dokuwiki/doku.php?id=en:emmc_recovery_xu3

And your suggestion.

The warranty period is poor - do you know of any non Hardkernel source of these modules that offer a decent warranty?

John

Hi again Fourdee,

Been asking for advice in Odroid forum but no success: https://forum.odroid.com/posting.php?mode=reply&f=97&t=26173

Have also tried to format using the utility you suggest but it sees the drive as being write protected.

Looks like another failed eMMC. The Odroid warranty period is poor given that they must buy these elsewhere so they should pass on faulty modules to their suppliers. I’m using a Sandisk SD in the meantime and it doesn’t seem that much slower for what I use the device for.

John