XU4 kernel upgrade

I want to try waking the XU4 with the RTC as here:


But my kernel is not recent enough at 4.9.29+ - this needs 4.9.47-58

If I do
root@Odroid:~# apt-get dist-upgrade

This is the response: (I have manually held back linux-image-3.10.105+)

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following NEW packages will be installed:
linux-image-3.10.106+ uboot
The following packages have been kept back:
The following packages will be upgraded:
1 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 12.6 MB of archives.
After this operation, 42.5 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Is it safe to do this or could I break the system?


Answering my own question - tried this with a cloned SD card and the system wouldn’t boot.

Hi John,

I got also this problem, and as there are no kernel updates for the XU4 in dietpi, I dropped dietpi and use now the official 4.9 minimal image.

I have to admin you have to figure out all the settings for your software by yourself (dietpi is easy to use) I can atleast update the kernel.


Hi John,

You can install the 4.9 kernel using the 4.9 kernel package provided by Meveric’s repo, please see link below:

Thanks Fourdee did this:

rm /boot/exynos5422-odroidxu4.dtb
apt-get update
apt-get install linux-image-4.9-armhf-odroid-xu3

And result is:

Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-image-4.9-armhf-odroid-xu3 : Conflicts: linux-image-3.10.105+ but 3.10.105-20170408-XU3 is to be installed
E: Unable to correct problems, you have held broken packages.

Any ideas?


Hi John,

Try removing conflicting 3.x package before install:

apt-get purge linux-image-3*
#Do not reboot system, until below is installed.
apt-get install linux-image-4.9-armhf-odroid-xu3

Untested, as my system is already 4.9, but should resolve it.

Thanks Fourdee I’ll try this later today - but note I am already on 4.9 just wanting the most recent kernel for the RTC wake up experiment.


Meveric updated 4.9 recently, should be good to go, let me know if not:
linux-image-4.9-armhf-odroid-xu3_4.9.58-1_armhf.deb 2017-10-24 05:39 1.4K

Worked perfectly thanks Fourdee.