XU4 Cloudshell 2 installation freezes

I have a XU4 Cloudshell 2 running for some time now.
Should have keep the system in its old state :cry:
But after a mistake during an dietpi update to bullseye I had to install a new dietpi img.

What happens now is that the system feezes after some time .
The time varies it could be hours or days. Before that the system was running stable for years.

I moved the system to my attached cloudshell HDD raid.
The dietpi sys was updated several time but no improvement.

When the system feezes then

  • both HDD lights on
    Fan running or off, depending at watch moment the freeze occurs
    cloudshell display shows the last active page
    the clock shows the last time at freeze
    no network connection

Also full logging is enabled but I dont find anything unusual.
As I am not the linux pro could you point me to some direction what I should post here to nail down the issue?

Kind regards
Schnitzelbrain

You could post the last logs before the freeze. Note that in case of a crash, the boot messages may be dated back until the network time sync has been done, hence they appear before and/or between the logs from before the crash. But boot sessions are separated/marked with a separation line which allows to find the ones from before and after the crash.

Did you use our latest image, from just a few days ago? It ships with a new kernel.

Hi there thx for the answer/questions.

No, its not the latest image. It was installed before and kept updated.

Regarding the logs, what are necesarry because I have to clean some private information out?
Kernel,SYS or DEBUG? All of them?

Regards
Schnitzelbrain

At best all log levels, so we also see e.g. last cron job and systemd timer execution, aside of possible kernel and/or system/service errors.

So, after 20 days of use after the last crash it crashed again.

please find the log files via PM. There is to much internal data in them, so I dont want to post them around. Cleaning them up would be pain in the butt.
If you need other additional files just drop me a note.

Schnitzelbrain

And froze again, after 2 days this time.

I uninstalled motioneye now, test it again.

The only thing that is left installed (out of the standard) is samba and syncthing.

regards

I’m sorry for the late reply. The loga show a crash on 26.05. shortly after midnight, either after a minutely cron job or after a logrotate job (not 100% sure whether this was on boot session before or after crash).

What does the minutely cron do?

Also the Cloudshell2 service at boot fails with a missing executable, how did you install it?

cloudshell-lcd.service: Failed to locate executable /bin/cloudshell-lcd: No such file or directory

No worries, thanks for the look and the reply!

To your questions, the minute cron checks the CPU temps and switches the cooling fan on or off depending on the temperature via a small batch script.

The lcd leftovers are from another display overlay I used (installed it via Script not using dietpi software) but uninstalled, at least I tried to. Now I use the dietpi supplied display software.

I uninstalled because I tried to troubleshoot the freeze but it crashed anyways. That said, maybe you can tell me where to look from where the start is executed from, so I can remove it manually to get rid of the error?

My last step was removing the motioneye because I saw some stream errors in the logs. It runs for approx 24 days now without freezing.

May 26 09:30:10 DietPi motion: [1:ml1:Keller] [WRN] [NET] netcam_next: called with no data in buffer
May 26 09:30:12 DietPi motion: [3:ml3:Balkon] [CRT] [NET] motion_init: Substream not available. Image sizes not modulo 16.

The log output looks very sparse as when it happens nothing seems to be written anymore and the next thing you see is the boot sequences. I am not sure if it crashes or if it is just freezing doing something and can’t do anything else. Most of the time the fan runs continously and the display just continue to show the last actual page. The clock shows the last active time.

I will let it run until it freezes again or at least for another month if it does, without touching anything.

Thanks again for the help
Schnitzelbrain