Xrdp/xfce and Windows remote desktop: File Browser starter in task bar is not working!

Enjoy your weekend :grinning:

Because it is a general design flaw, I did not have a closer look. Usually, I don’t care which bloated feature they want to throw down my throat, I most times vote with my feet and go somewhere else.

The @jock link should have already all answers.

As an early bird, you need to use a kernel with the patch applied, alternatively you can wait for it to land in mainline and the version to trickle into your distribution.

1 Like

I oversaw the link :smiley:

Which version of the kernel does include the MGLRU patch? 5.18 and later eventually?

For Ubuntu, I normally use Ubuntu Mainline Kernel Installer. Is there something similar for raspberry pi/debian (preferrably via cmd line)?

I guess I will follow this link:

For Raspberry Pi (only) GitHub - raspberrypi/rpi-update: An easier way to update the firmware of your Raspberry Pi

1 Like

I will follow that! And regarding my “buster” problem, I can’t dist-upgrade to the latest debian version. So I now make the unnice sober way and prepare a new sd card. I have to try to reinstall every service and app again… I hoped for a more convenient solution, as I did not write down all installation steps. :frowning:

what is blocking you?

@Joulinar

root@DietPiPaeddasBKServer:~# apt update
OK:1 https://deb.debian.org/debian buster InRelease
Holen:2 https://deb.debian.org/debian buster-updates InRelease [56,6 kB]
OK:3 https://packages.grafana.com/oss/deb stable InRelease
OK:4 http://giteduberger.fr rpimonitor/ InRelease
Holen:5 https://archive.raspberrypi.org/debian buster InRelease [32,6 kB]
OK:6 https://download.mono-project.com/repo/debian buster InRelease
OK:7 https://deb.debian.org/debian-security buster/updates InRelease
Holen:8 https://deb.debian.org/debian buster-backports InRelease [51,4 kB]
Holen:9 https://archive.raspberrypi.org/debian buster/main arm64 Packages [302 kB]
Es wurden 443 kB in 3 s geholt (154 kB/s).
Paketlisten werden gelesen... Fertig
Abh▒ngigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.

root@DietPiPaeddasBKServer:~# apt upgrade
Paketlisten werden gelesen... Fertig
Abh▒ngigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 20 nicht aktualisiert.

root@DietPiPaeddasBKServer:~# apt dist-upgrade
Paketlisten werden gelesen... Fertig
Abh▒ngigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 20 nicht aktualisiert.

So it simply does nothing! “upgrade” shows: 20 packages are not actualized. I have already googled for that and that’s why I have a feeling that this issue is a weird one…

What do you think?

P.S.: BTW what is actually recommended to download? arm64 or still arm32 bit image? What is the downside of 64 bit (as it is a 64 bit platform, the raspberry pi 4b 2GB)?

there could be some pinning of packages blocking the update. Can you try following

apt list --upgradable

Well, depends on personal preferences. There might be some pro and cons but nothing dramatically.

root@DietPiPaeddasBKServer:~# apt list --upgradable
Auflistung... Fertig [Listing.... Ready]

I am desparated, I am sure, I did not really something weird to the system! The information is not really helpful…

Regarding 64 bit I thought it might be best for performance using 64 bit?? I thought problems in the past result from the fact, that not all apps are 64 bit capable or available?

Could it simply be, that my ressources of GPU ram is not sufficient to drive full hd resolution (1920x1080)?

This question can only be answered by the one building the kernel you want to use. I build my kernels myself and add the patch when it is available for the version in question. It was often not available for all rc candidates and I immediately noticed by the operating behavior it’s missing.

1 Like

So for me as I am not used to it, it is a more huge effort, I guess I would need half a day for the first time…
You are confident this will be part of the kernel soon? Do you know if the kernel people do test it and prove it already? Is the importance of the impact already accepted? What is your “feeling”?

My approach is to trying to find out if this issue is the main issue to my problem, or “only” one of the problems…

I don’t really know, I just pick it up in the flyby. @hexdump or the developer @yuzhaogoogle from @jocks thread should be able to make better statements. But even if it ends up in 5.20.0, it will still take quite a while before it will arrive out-of-the-box in the distributions.
Your best bet would be if there is an MGLRU patch for your desired kernel version and you either build the kernel yourself or use a prebuild.

OOM has always been a problem, no matter what you do, sooner or later there will be another process that requires more memory than available. You can mitigate it with more memory or its better use, but you will always lose because developers will not tire of implementing new bloating functionalities. But OOM is only a minor problem compared to many more serious others if you can prevent functionality bloating.

I set up a new dietpi with new software. When I log in to user pi (root is not allowed), and start firefox, and after it chromium, the system comes nearly unusable, at least in the gui…


The last picture, is when I try to open custom settings, of chromium, took nearly 2 min. Signing in was not reacting…

I am using Remote Desktop on Windows and connect via XORG (the only profile which works anyway, vnc is only working standalone (at least this was my experience so far…)

User pi is not a available on DietPi. Did you create one manually? And why is root user not working? There should be no limitation, if not set manually.

Looks like you are close to full memory usage and the system starts swapping. This of course will lead to slowness.

As well swap seems to be exceeded on the last picture which will result in the system start killing processes or crashes.

1 Like


Bit you see I just opened some tabs , here I actually have a problem installing your gitea, so I tried out a debian 11 helper page. It only took a few miniutes to be inaccessible.,…

I killed the process, because it killed everything. Such as it is I am not able to use the system with a graphical ui. I set up the GPU to 384 MB but that did not bring the solution, now I am quite sure that it is the exact wrong way, because it takes memory away from the system…

I had once a Pi 4b with 8GB but I destroyed it (nearly, it works now as a PIcoreplayer, but it has no IO except the display and the wlan ;-)), but I am pretty sure to have had the same issues with it as well.

I think you are right, but what is the solution then? Not to use it!

As user root, I retried it with the newly set up machine:

Only green screen, even no notice of failing…

It was working with the old system. I did install:

  • XORG
  • XFCE
  • XRDP
  • LXDE

Because I always log in from my company’s laptop (which is mostly quite fine), I also used my rarely used windows laptop (private) and tried it out with the same result. So we can exclude odd vpn issues here as well. Would have wondered me though, cause it was working with the other sd card a coupe of hours … (but as I now remember, and what was wondering me, with LXDE!!)

I have to change back to LXDE maybe. But it is installed as well… there must be a config for that. I try to google that…

Interesting information I found in my memories:
I remember that Xvnc as a connection option with xrdp is much more efficient than XORG. But xorg with user pi is the only option working.

I tried to install tigervnc with xfce: Now I can log in as user root or in othe words, it only accects user root in the default config…AND user pi could log in via XRDP/Xvnc. So at least this stays consistent!!

Open Questions:
How can I quickly change between XFCE and LXDE for

  • XRDP/XORG
  • XRDP/XVNC
  • tigervnc

And how can I configure XRDP to use Xnvc on dietpi?

I am now not capable of creating any items in the dock panels. I can delete it but I am not able to change anything xrdp/xorg or xrdp/xvnc…frustrating. I can add a new panel, without being able to change any settings.

Question: i boot on serial tty into teminal. Do I have to setup here a desktop gui as well?

And I am always talking about XFCE, but in fact, only in xvnc it is connecting to XFCE, the other (XRDP) still connect to LXDE…

I’m not 100% sure but I guess you can’t run 2 different desktop next to each other. It would need to be Xfce or LXDE.

@MichaIng
Do you know if Xfce and LXDE can be installed in parallel?

1 Like