Wireguard not in dietpi-software repo

I tried to add a VPN to my server and decided to go with wireguard. From the main software thread it looks like it’s in the software-repo, but i can’t find it.
I already updated to the latest dietpi version, did apt update and apt upgrade, but it’s still not appearing.
Is there a way to update the software repo?

havanaboy11
We have not yet enabled it for all devices. Kernel headers and in cases special build requirements are needed to get it running.
Which SBC do you use?

To check: dietpi-software list | grep wireguard

Ahh i see. Thank you.
Using an old Bananapi M1 until i will get my Pi 4.

Looks like Lemaker stepped up with their game and is distributing now Debian 10. When i started last year, there was only Raspbian/Bananian with Wheezy, so i had to manually update it to Stretch to be able to use DietPi

If you find headers for your currently installed kernel on the BananaPi, or they are already pre-installed, you can simply try to installall WireGuard from the Debian Bullseye repo. If required, I can provide some instructions later.