Wired Ethernet on Connecting at Power-Up on Raspberry Pi 3

Okay, when this is new with this DietPi version, I’m petty sure it’s due to the new kernel.

Just in case it got solved in master branch, please try first up upgrade it:

apt install rpi-update
rpi-update

If this does not help, try to downgrade it to latest v5.4:

rpi-update 453e49bdd87325369b462b40e809d5f3187df21d

If this helps, we should report it to the Raspberry Pi Linux repository: https://github.com/raspberrypi/linux/issues

Hi , I am new here. I am using Raspberry Pi 3A and it also does not connect to the Ethernet eth0. When I boot using Raspberry OS Legacy it works fine. I initiated wi-fi wlan0 using an USB dongle and it works. I tried ifdown eth0 and ifup eth0 and it does not get a DHCP response after trying several times. My router is on during this tests. Also, I noted that dietpi thinks it is a Raspberry Pi3B instead. Would you check bugreport dd16c031-9746-4bda-9aea-3ff9e4534fda ? Many thanks in advance.

can you check if the Ethernet cable is connected correctly?

There you have following message on the log

[  234.382545] smsc95xx 1-1.1:1.0 eth0: Link is Down

and

2: eth0: <NO-CARRIER