Wired Ethernet on Connecting at Power-Up on Raspberry Pi 3

I was able to fix it once I could see the boot-up session.

I read this post: https://dietpi.com/forum/t/ntp-systemd-timesyncd-issue/2742/1

I modified the time sync mode to custom.
dietpi-config > Advanced Options and choose “custom” as time sync mode.

I am not sure why this was preventing the system from booting up.