WinringPi not installing

I downloaded the latest DietPi for Raspberry Pi (Jessie) last night and installed a few bits. However one item I wanted was WiringPi, this came up with a github error, repository not found. It seems to be linking to a specific release, rather than the latest.

I reverted to the traditional git clone… ./build and it is now all working.

All good now, but something seems broken within the DietPi setup of this piece of software.

Hi keithellis,

Sorry to hear this. Have done a quick look in the code at:

It load the last version (v2.32) from the authors website: The Drogon Network | Crow

But for example github have massive connecting issue in the last days.



Sometimes it will help, to try installation later again.

Thanks, yes the link in the code looks correct. Very strange through. I tried several times and it failed every time using dietpi-software.

However when I cloned manually using git it worked straight away, maybe just luck.

By the way, this is on a Raspberry Pi model B, revision 2 (26 way header).

Cheers,
Keith.

Git Ticket: https://github.com/Fourdee/DietPi/issues/352