Why use Debain Bullseye if it will not work with pihole?

I have spent my morning and afternoon banging my head against a brick wall. I can install dietpi perfectly, but pihole fails to a non supported version. Debain has not even released a true stable version yet. So now I am without my DNS server and black hole, because it fails to function with and unsupported OS. A bit short sighted isnt it? Very MS esque.

So now I have to hunt down and older diet pi, install it, stop the upgrade, install pihole, dont upgrade anything and then one day wait for bullseye to be declared stable.

Unless you have created a work around, oh BTW the ignore the OS version doesnt fix it, in fact there is not a script I have found that has, short of a third party that is sketch.

I’m not really able to follow you. Debian Bullseye has been released as stable a week ago and for me installation of Pihole is working fine on a RPi3B+ running ARMv7 Debian Bullseye. No issue with an unsupported OS.

If you don’t like Bullseye, you are free to download our Buster image which is still available on our download servers.

Ok let me clear it up.

New Debain, not compatable with current pihole.

Me – updated to current release, cant install pihole, due to current release of debain.

clear so far?

Hours of frustration, looking for fixes, trying several, not working and not happy. My network is exposed.

Wondering why an OS that was not stable, and still isnt even though they call it stable, is being used.

You offer a solution, good on you becaue you are not trying to deflect, but would have liked a link.

Concerned that no matter the version I use, that it will upgrade, and cause the same issue that is going on now.

After checking the only images I can download from your DL page are debain images…

No link to another page, no access to a rollback…

New Debain, not compatable with current pihole.

This is not correct. I did a test half a hour ago and I was able to install PiHole on a RPi3B+ running Debian Bullseye ARMv7 as well as on a RPi1 running Raspbian Bullseye ARMv6. Installation was done using dietpi-software.

updated to current release, cant install pihole, due to current release of debain

dietpi-update will never do an upgrade of a Debian version. This would need to be done by yourself or by installing a new image.

Wondering why an OS that was not stable, and still isnt even though they call it stable, is being used.

Not correct. Debian Bullseye has been released as stable a week ago. Officially.

Concerned that no matter the version I use, that it will upgrade, and cause the same issue that is going on now.

Same as above, dietpi-update will not trigger any Debian version upgrade

but would have liked a link

https://dietpi.com/downloads/images/

Added a link to PiHole Support Platform as the requestor opened same issue over there as well https://discourse.pi-hole.net/t/pi-hole-not-installing-diet-pi-7-2/49162

Im on Bullseye, RPi 3 (aarm64), DIetPI 7.6.x and installed PiHole using dietpi-software. All works like a charm. :slight_smile:

The recent Pi-hole release supports Bullseye as well when installing it manually via their installer. Via dietpi-software it worked already long before.