Wake over LAN WOL dietpi x86 pc

I reboot many time, i have another raspberry running homeassistant & in that i created switch for wol for my server. shell_command: turn_off_server: "ssh -i /home/homeassistant/.ssh/id_rsa homeassistant@ 'sudo systemctl hibernate'" & it is working fine for hibernate. the wol start thing fail to wake up machine. it was working before. even i tried to send wol magic data through wrt router & android app. but system is not wake up by any method. i have to click the hard start button to boot the machine.

You checked the config still be present on your network configuration file?

Thanks Joulinar & Jappe, after giving all these commands & with your expert guidance i confirm that dietpi/operating system wise every thing working. then i did brainstorming & check each component backward. i checked router port, UFW ports etc. & then in last i check my NUC BIOS setting. then i found the reason for why wol was not working. the reason was my NUC is old & may be the battery on motherboard exhausted. last week there may be power outage for some time & my nuc forget its settings & start using default setting with WOL disable. I reconfigure my motherboard settings & WOL again start working. so i confirm WOL works on dietpi nuc. thanks