USB dries not being recognized

Creating a bug report/issue

Required Information

- DietPi version: G_DIETPI_VERSION_CORE=8
G_LIVE_PATCH_STATUS[0]=‘not applicable’

- Distro version: bullseye 0

- Kernel version: Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux

- Architecture: arm64

- SBC model: RPi 4 Model B (aarch64)
- Power supply used: 5V 1A RAVpower
- SD card used: SanDisk

After inserting the USB drive, I invoke “Dietpi-software”, “User Data Location”, and “List”, and I only see the boot and main program file location, nothing else. I then launch Drive-Manager and see same.
After exiting, run “mount”, don’t see it, run “cat /etc/fstab” and see only the main two physical drives for Dietpi, no sda1 mounts.

I tried a few USB storage devices, both external and flashdrives, and tried both the USB2 and USB3 ports on my R-PI, all to no avail.

Now, everything I’ve read states they should just automount and with every other distro for the R-Pi I’ve run they just mount.

Is there anything I can try, or am I overlooking something?


You need to use dietpi-drive_manager to mount the drive. This script creates an entry in the fstab, after reboot the drive is mounted automatically if anything tries to access it.

1 Like

We don’t mount drives automatically just while they plug in. You need to use dietpi-drive_manager to configure the mount point. If drives are not visible there, they are not recognized by the system at all. You can verify available drives using following command.

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid