Upgrade fails: Repository ... changed its 'Suite' value from 'testing' to 'stable'

On Raspberry Pi, I am trying to upgrade DietPi from v6.26.3 to v6.28.0. The dietpi-update command is failing. Here’s what it prints when I exit dietpi-update:

#### Details:
- Date           | Sun  5 Jan 22:18:22 CST 2020
- Bug report     | N/A
- DietPi version | v6.26.3 (MichaIng/master)
- Image creator  | DietPi Core Team
- Pre-image      | Raspbian Lite
- SBC device     | RPi 4 Model B (armv7l) (index=4)
- Kernel version | Linux dietpi-music 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l GNU/Linux
- Distro         | buster (index=5)
- Command        | G_AGUP
- Exit code      | 100
- Software title | DietPi-Update

#### Steps to reproduce:
<!-- Explain how to reproduce the issue -->
1. ...
2. ...

#### Expected behaviour:
<!-- What SHOULD happen? -->
- ...

#### Actual behaviour:
<!-- What IS happening? -->
- ...

#### Extra details:
<!-- Please post any extra details that might help solve the issue -->
- ...

#### Additional logs:

Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Hit:2 https://archive.raspberrypi.org/debian buster InRelease
Reading package lists…
E: Repository ‘http://raspbian.raspberrypi.org/raspbian buster InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘stable’

Looks like the fix might be for the dietpi-update script to call apt-get update with the “–allow-releaseinfo-change” option. But I’m not 100% sure this is right, and even if it is right, not sure where to hack that option in…

Anyone else encounter this?


hmm, I did quite some updated for testing purposes on the last days without any issues. Even yesterdays evening I did one on my RPi4. pls can you run dietpi-update again to check if the issue still persist.

Tried running it numerous times, always the same result.

I went ahead and tracked down the G_AGUP function, and added the “–allow-releaseinfo-change” option to the apt-get update command. Specifically, I edited the file /DietPi/dietpi/func/dietpi-globals, changing this line:

DEBIAN_FRONTEND=noninteractive apt-get -q update 2>&1 | tee -a $G_FP_LOG_APT

to this:

DEBIAN_FRONTEND=noninteractive apt-get -q update --allow-releaseinfo-change 2>&1 | tee -a $G_FP_LOG_APT

After that little hack, the upgrade worked.

Many thanks for your report. Jep due to Buster stable release a single manual apt update call is required to accept the suite change for RPi Buster images created prior to official Buster release. Since this is a one-time action and generally unexpected suite changes should not be accepted non-interactively, I did not add the option you suggest to our G_AGUP command. Our downloadable images already have the suite accepted, hence the amount of users who have an older image and did never run “apt update” manually until now, should be tiny.

But since we now know about this issue, in 1.5 years, we’ll take care that either no “stable”-marked images are released which do not have the suite change accepted, or temporarily add the option to all pre-released Debian Bullseye images then.