Update from 148 to 149 does not work


I tried to update my raspi from dietpi 148 to 149 by using “dietpi-update”. A lot happens and finally the update process asks me to reboot.
After the reboot the system still says that I can update from 148 to 149.

I tried it several times but always the same.

What can I do?

Best regards,

@Fourdee: Do you have any advise on how to get the update running?


Please paste results:

df -h
systemctl status dietpi-ramdisk -l

And, during the update, do you notice any on screen errors?

root@maschine2:~# df -h
Filesystem             Size  Used Avail Use% Mounted on
/dev/root               15G  1.7G   13G  12% /
devtmpfs               459M     0  459M   0% /dev
tmpfs                  463M     0  463M   0% /dev/shm
tmpfs                  463M   24M  440M   6% /run
tmpfs                  5.0M  4.0K  5.0M   1% /run/lock
tmpfs                  463M     0  463M   0% /sys/fs/cgroup
tmpfs                   10M  1.2M  8.9M  12% /DietPi
tmpfs                   20M   36K   20M   1% /var/log
tmpfs                  463M     0  463M   0% /tmp
/dev/mmcblk0p1          60M   23M   38M  38% /boot  1.8T  909G  924G  50% /mnt/nas
root@maschine2:~# systemctl status dietpi-ramdisk -l
● dietpi-ramdisk.service - DietPi-RAMdisk
   Loaded: loaded (/etc/systemd/system/dietpi-ramdisk.service; enabled)
   Active: active (exited) since Thu 2017-05-04 03:17:10 CEST; 3 weeks 6 days ago
  Process: 600 ExecStart=/bin/bash -c /boot/dietpi/dietpi-ramdisk 0 &>> /etc/dietpi/logs/dietpi-ramdisk.log (code=exited, status=0/SUCCESS)
  Process: 572 ExecStartPre=/bin/mkdir -p /etc/dietpi/logs (code=exited, status=0/SUCCESS)

May 04 03:17:10 maschine2 systemd[1]: Started DietPi-RAMdisk.

No, I did not see any error messages.

Thanks. Looks ok. Lets try updating and forcing ramdisk to save (instead of during shutdown phase).

Please try running the update:


Then forcing saving RAMdisk:

systemctl stop dietpi-ramdisk

Check successful with (should return 150):

cat /boot/dietpi/.version

If ok, reboot system and check login reports v150.

Thanks for your support!
The results are:

Before reboot it shows version 150.
After reboot it shows version 148.


It is the same behaviour for the new update to 151 :frowning:


i have got the same problem with 148 to 150 and now to 151.

Always the same with Reboot to 148. But after i did this :

systemctl stop dietpi-ramdisk

Everything works fine.

Thanks a lot.

Cu kami

You disabled the ramdisk before running the dietpi-update command?

No, after the update.

When run this command after the update to switch off the ramdisk I see the following things:

  • After next reboot the ramdisk is on again
    Without ramdisk I might have lower performance
    AND: Even switching the ramdisk off after the update the /boot/dietpi/.version will still show 148

So this obviously does not work for me :frowning:

anyone have a fix? stuck on 150, can’t go to v151 @Fourdee

Do you have PiHole installed?

No, what is it?

Great :slight_smile: https://dietpi.com/forum/t/dietpi-survey-information/32/1

Our update system appears to be fully functional at the moment. We cant replicate this at our end.
Have you made any changes to the system (eg: installed software/changed a config), outside of the DietPi scripts (eg: manually)?

I am running the LAMP stack and also Python scripts. I installed some additional Python modules.
And additionally I mounted my NAS via /etc/fstab. Furthermore I applied some cron jobs at /etc/crontab.

When I reboot the machine at Login I can see “UPdate available”. /boot/dietpi/.version will show me “148”.
Can you help me investigate on the root cause? For example:

  1. Can I check in any way if I have the latest builds on my raspi (dietpi-update will do something but I cant’f figure out if it all succeeds).
  2. When will the new version be written to /boot/dietpi/.version? And what might have happened if writing to this file does not succeed?

    Here are some details from my last dietpi-update run:

    [Ok] kernel dietpi_rpi | Completed

[Ok] Patch 150 completed

Mode: Updating DietPi
Please wait…

[Info] Current Version : 150
[Info] Server Version : 151

[Info] Patching 150 to 151
[Info] Checking RootFS R/W access. Please wait…
[Ok] RootFS R/W access.
[Info] Initializing database, please wait…
[Info] Reading database, please wait…

Mode: Automated reinstall
Please wait…

[Info] 37: Shairport Sync is not currently installed
[Info] The program must be installed, before reinstall can be used
[Ok] No changes applied for: Shairport Sync
[Ok] Patch 151 completed

Mode: Completed
Please wait…

[Info] Current Version : 151
[Info] Server Version : 151
[Ok] Update completed

After this dietpi-update run the /boot/dietpi/.version still shows 148 :frowning:

Best regardsm

Are there any other actions I can take to get the Pi updated properly? Even the latest update to 153 results in the same behaviour.

Is there a chance to check if the dietpi-update command did all updates but only the wrong version will be shown?


Most likely dietpi-ramdisk is failing to save on shutdown.

After updating DietPi, try forcing a ramdisk save and checking status:

systemctl restart dietpi-ramdisk
systemctl status dietpi-ramdisk -l

If it reports active and success, reboot system and recheck version.


can someone explain this to me?

Loggin in does not seem to ask for an update:

DietPi | 21:50 | Wed 12/07/17
V153 | RPi 3 Model B (armv7l)
IP Address |

Created by : Daniel Knight
Web : http://DietPi.com
Twitter : http://twitter.com/dietpi_
Donate : http://goo.gl/pzISt9
DietPi’s web hosting is powered by: MyVirtualServer.com

dietpi-launcher = All the DietPi programs in one place.
dietpi-config = Feature rich configuration tool for your device.
dietpi-software = Select optimized software for installation.
htop = Resource monitor.
cpu = Shows CPU information and stats.

In the .version file I can find 148:

root@maschine2:~# cat /boot/dietpi/.version

dietpi-update determines version 153:

root@maschine2:~# dietpi-update
[Info] Checking RootFS R/W access. Please wait…
[Ok] RootFS R/W access.

Mode: Checking for DietPi updates
Please wait…

[Info] Checking Mirror : http://dietpi.com/downloads/dietpi-update_mirror/master/server_version
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 6 100 6 0 0 103 0 --:–:-- --:–:-- --:–:-- 115
[Ok] Using update server: http://dietpi.com/downloads/dietpi-update_mirror/master/server_version
[Info] Detecting drives, please wait…
[Info] Detected /dev mount: /dev/mmcblk0p1 > /boot
[Info] Detected /dev mount: /dev/mmcblk0p2 > /
[Info] Processing drive information, please wait…
[Info] Checking available free space on RootFS, please wait…
[Ok] 13178 MB available, 500 MB required

[Ok] No updates required, your DietPi installation is up to date.

[Info] Current Version : 153
[Info] Server Version : 153

So the only weird thing is why /boot/dietpi/.version is outdated? How can I fix that?