Unable to run dietpi-update without disableing IPv6

Required Information

  • DietPi version | v8.14.2
  • Distro version | Bullseye
  • Kernel version | 5.15.84-v7+ #1613 SMP
  • SBC model | RPi 3B+
  • Power supply used | Anker
  • SD card used | Transcend 32GB High Endurance


I’m using the DietPi as a GPS NTP server. GPSd requires IPv6 to be enabled to work properly for some reason but I don’t have an outbound IPv6 network available to the Internet at this moment. So every time I run the dietpi-update with IPv6 enabled it tries to PING 2620:fe::fe and fails. I was wondering if there is an option to skip the IPv6 ping check so I don’t have to disable IPv6 every time I need to run dietpi-update.

I think you can hit change command and type in true and go one.

1 Like

Theoretically you could adjust the IPv6 ping check to point to your local device. Another option is to check if IPv6 requirement could be disabled on gpsd. Can you share following

cat /lib/systemd/system/gpsd.socket

Based on GPSD could not start with disabled ipv6 (#112) · Issues · gpsd / gpsd · GitLab

Description=GPS (Global Positioning System) Daemon Sockets

# To allow gpsd remote access, start gpsd with the -G option and
# uncomment the next two lines:
# ListenStream=[::]:2947
# ListenStream=


These 2 options seem to force IPv6. You could try to change this


Hope that this will let service start using IPv4 only.


This is a temp workaround that would need to be done each time :wink: Better to disbale IPv6 to avoid this manual work.

1 Like

It worked. Hopefully, the file won’t get replaced by a newer update.