Unable to install Ceph on a new DietPi installation

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8

  • Distro version | bullseye

  • Kernel version | Linux chalkoarai-1-r5c 5.10.110 #1 SMP Sat Dec 3 01:06:07 CST 2022 aarch64 GNU/Linux

  • SBC model | NanoPi R5S/R5C (aarch64)

  • Power supply used | 5v 3A

  • SD card used | EMMC

Additional Information (if applicable)

  • Software title | ceph

Steps to reproduce

On a new installation (following this tutorial: Deploying a new Ceph cluster — Ceph Documentation)
curl --silent --remote-name --location https://github.com/ceph/ceph/raw/quincy/src/cephadm/cephadm
chmod +x cephadm
./cephadm add-repo --release quincy
./cephadm install

Expected behaviour

This should have installed cephadm

Actual behaviour

I ran into this issue :

dietpi@chalkoarai-1-r5c:/tmp$ sudo ./cephadm install
Installing packages ['cephadm']...
Non-zero exit code 100 from apt-get install -y cephadm
apt-get: stdout Reading package lists...
apt-get: stdout Building dependency tree...
apt-get: stdout Reading state information...
apt-get: stdout Package cephadm is not available, but is referred to by another package.
apt-get: stdout This may mean that the package is missing, has been obsoleted, or
apt-get: stdout is only available from another source
apt-get: stdout
apt-get: stderr E: Package 'cephadm' has no installation candidate
Traceback (most recent call last):
  File "/tmp/./cephadm", line 9653, in <module>
  File "/tmp/./cephadm", line 9641, in main
    r = ctx.func(ctx)
  File "/tmp/./cephadm", line 8123, in command_install
  File "/tmp/./cephadm", line 7751, in install
    call_throws(self.ctx, ['apt-get', 'install', '-y'] + ls)
  File "/tmp/./cephadm", line 1852, in call_throws
    raise RuntimeError(f'Failed command: {" ".join(command)}: {s}')
RuntimeError: Failed command: apt-get install -y cephadm: E: Package 'cephadm' has no installation candidate

Extra details

I tried to google this error message but didn’t find any satisfying results. I also tried other ceph release (pacific) but met the same issue.

I do not see in their installer where the repo URL is coming from and hence whether it even provides ARM packages. Can you check:

cat /etc/apt/sources.list.d/ceph.list



looks like AMD64 packages only on Debian.

Interestingly there are ARM packages as well, but cephadm on Debian is available for AMD64 only indeed. For Ubuntu there is an ARM64 package as well: Index of /debian-quincy/pool/main/c/ceph/

So in short: No native ARM support. You can try to install the arm64 package for Ubuntu manually and see where this brings you. Likely additional packages need to be installed as dependencies. You may asp the ceph guys to provide ARM64 support as well for their Debian repository. Should be trivial as they provide those for Ubuntu already.

1 Like

@Ypresis you would need to ask software provider if there is a way to install cephadm on ARM. At least I was not able to find a GitHub repository for cephadm

Thank you for your answers! I’ll give the Ubuntu packages a try.