Unable to connect to DietPi after update

I’ve got an Allo USBridge. I installed the latest clean image v6.18.14. Using PuTTY, I ran dietpi-update which appeared to work without incident. After the reboot though, it showed as still running v6.18.14. After a subsequent reboot, I can no longer login via SSH. DietPi-RAMlog: Unknown argument: -1 Aborting…

When did you do that? The issue, that the update does not seem to be applied after reboot, could occur when updating to v6.20, but since earlier February v6.21 is live which should not have this issue anymore.

DietPi-RAMlog: Unknown argument: -1. Aborting…

There must have something gone terribly wrong. This error means that something called /DietPi/dietpi/func/dietpi-ramlog or /boot/dietpi/func/dietpi-ramlog on login with argument -1 which is invalid for this script. And within our code we never call it manually, always via systemd unit: /etc/systemd/system/dietpi-ramlog.service.
This is called during early boot stage and prints it’s output to a log file only, so never to terminal and especially not on during to the SSH session.

And another thing I wonder:
When installing a fresh image, the update to the most current version should be applied automatically, so no manual dietpi-update run required.

Which device do you use?

I suggest you re-flash the image. At best attach monitor and keyboard when doing first boot to catch any errors during boot (some about serial-console@ttyS0/AMA0 are expected, just in case).
If you used an SDcard and have another one by hand, please switch it. I once had randomly mixed characters in certain files due to SDcard corruption.

I think you’re right.
I removed the eMMC and reflashed it with DietPi_SparkySBC-ARMv7-Stretch and now it works.