Ubiquiti Controller installation

Hi there,

I’m planing on installing Ubiquiti Controller on my RPi4 with latest Dietpi 64 Bit. I found a way to use the newer Java Version 11 instead of old 8. However, how can I install and use a version of Mongo DB that’s not ancient? Did anyone manage?

Thx Daniel

Basically MongoDB 5 is not supporting ARM based systems at all. As well there is no Debian repository available directly. You would need to use MongoDB 4 as Docker container or as native app from Ubuntu repository.


Thx a lot. I was able to install the Ubuntu Version. However I’m still not able to install Unifi Controller as it’s still saying I need to install mongo db. Maybe it’s because Mongo DB 3.6 is needed.
I give it some more hours to investigate next week. However, in worst Case I’ll need to Install Ubuntu LTS 20.4 and wait until Ubiquiti updates their Controller to support Dependencies that are not EOL (of course this isn’t on DietPi). Would be a pity I’d prefer the much more efficient DietPi everything else worked without out of the box.

Basically issue is with Unifi as they did not update their controller software for ages and still require old outdated software. You could try using a MongoDB Docker container to get mongo:3.6.23


As analternative, you can use linuxserver/unifi-controller Docker container to get it directly running